Skip to content

My first lab with Junos

Topology

                  vlan-id 10
  ------                             ------
 !      ! .1    192.168.10.0/30   .2!      !
 !  R1  !---------------------------!  R2  !
 !      ! fxp1.1             fxp2.1 !      !
  ------                             ------
lo0.1 1.1.1.1/32                  lo0.2 2.2.2.2/32

iwing (ttyd0)

login: root
Password:

root@iwing% 3R2.8 built 2007-07-07 00:23:06 UTC
root@iwing%
root@iwing% cli
root@iwing>
root@iwing> configure
Entering configuration mode
[edit]
root@iwing#
[edit]
root@iwing#
root@iwing# set logical-routers R1
[edit]
root@iwing# edit logical-routers R1
[edit logical-routers R1]
root@iwing#
[edit logical-routers R1]
root@iwing# set interfaces lo0.1 family inet address 1.1.1.1/32
[edit logical-routers R1]
root@iwing# set interfaces fxp1.1 family inet address 192.168.10.1/32
[edit logical-routers R1]
root@iwing# set interfaces fxp1.1 vlan-id 10
[edit logical-routers R1]
root@iwing# show
interfaces {
    fxp1 {
          unit 1 {
             vlan-id 10;
             family inet {
                    address 192.168.10.1/30;
             }
          }
     }
     lo0 {
         unit 1 {
             family inet {
                   address 1.1.1.1/32;
             }
         }
     }
}

[edit logical-routers R1]
root@iwing#

root@iwing# set logical-routers R1
[edit]
root@iwing# edit logical-routers R2
[edit logical-routers R2]
root@iwing#
[edit logical-routers R2]
root@iwing# set interfaces lo0.2 family inet address 2.2.2.2/32
[edit logical-routers R2]
root@iwing# set interfaces fxp2.1 family inet address 192.168.10.2/32
[edit logical-routers R2]
root@iwing# set interfaces fxp1.1 vlan-id 10
[edit logical-routers R2]
root@iwing# show
interfaces {
    fxp2 {
        unit 1 {
           vlan-id 10;
           family inet {
               address 192.168.10.2/30;
           }
        }
    }
    lo0 {
         unit 2 {
             family inet {
                  address 2.2.2.2/32;
             }
         }
    }
}

[edit logical-routers R2]
root@iwing#

[edit]
root@iwing# commit
commit complete

root@iwing> ping 192.168.10.2 logical-router R1

PING 192.168.10.2 (192.168.10.2): 56 data bytes
64 bytes from 192.168.10.2: icmp_seq=0 ttl=64 time=2.754 ms
64 bytes from 192.168.10.2: icmp_seq=1 ttl=64 time=2.670 ms
64 bytes from 192.168.10.2: icmp_seq=2 ttl=64 time=0.435 ms
64 bytes from 192.168.10.2: icmp_seq=3 ttl=64 time=0.438 ms
64 bytes from 192.168.10.2: icmp_seq=4 ttl=64 time=0.433 ms
64 bytes from 192.168.10.2: icmp_seq=5 ttl=64 time=0.434 ms
64 bytes from 192.168.10.2: icmp_seq=6 ttl=64 time=0.434 ms
64 bytes from 192.168.10.2: icmp_seq=7 ttl=64 time=0.431 ms
64 bytes from 192.168.10.2: icmp_seq=8 ttl=64 time=0.438 ms
64 bytes from 192.168.10.2: icmp_seq=9 ttl=64 time=0.435 ms
64 bytes from 192.168.10.2: icmp_seq=10 ttl=64 time=0.435 ms
64 bytes from 192.168.10.2: icmp_seq=11 ttl=64 time=0.437 ms
^C
--- 192.168.10.2 ping statistics ---
12 packets transmitted, 12 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.431/0.815/2.754/0.849 ms

Final Configuration
root@iwing>

root@iwing# show
## Last changed: 2010-02-10 11:37:28 UTC
version 8.3R2.8;
system {
 host-name iwing;
 root-authentication {
 encrypted-password "$1$bd4ySf8Q$EaiiIc24ycXAWCQHKOJCf0"; ## SECRET-DATA
 }
 services {
       ftp;
       telnet;
 }
 syslog {
     user * {
        any emergency;
     }
     file messages {
        any notice;
        authorization info;
     }
     file interactive-commands {
         interactive-commands any;
     }
  }
}
logical-routers {
   R1 {
      interfaces {
         fxp1 {
            unit 1 {
                vlan-id 10;
                family inet {
                     address 192.168.10.1/30;
                }
            }
         }
         lo0 {
            unit 1 {
               family inet {
                     address 1.1.1.1/32;
               }
            }
         }
     }
 }
 R2 {
     interfaces {
         fxp2 {
             unit 1 {
                vlan-id 10;
                family inet {
                    address 192.168.10.2/30;
                }
             }
         }
         lo0 {
            unit 2 {
                 family inet {
                       address 2.2.2.2/32;
                 }
            }
        }
    }
 }
}
interfaces {
    fxp0 {
       unit 0 {
           family inet {
                 address 1.2.3.4/24;
           }
       }
    }
    fxp1 {
        vlan-tagging;
    }
    fxp2 {
        vlan-tagging;
    }
    fxp3 {
        vlan-tagging;
    }
    fxp4 {
        vlan-tagging;
    }
}

[edit]
root@iwing#

Good luck

Special thanks to
1.Mr.Himawan
2.Torkis Narama Siregar

"It is also important to remember that Olive exists because Juniper allows it to exist, 
and is a testament to the mutual respect between the extremely knowledgeable developer 
and user bases. If the Olive platform became widely abused, Juniper could easily add 
additional software checks to prevent it from working. Please do not abuse this 
feature by doing stupid things like contacting JTAC for support on an Olive, 
or selling illegal copies of the software as "router simulators". 
This type of activity is likely to have serious legal consequences and/or 
provoke a justified response from Juniper, so just don't do it."
No comments yet

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: