Skip to content

My 2nd Lab with Junos (Static Routing)

Static Routing
Topology
                 vlan-id 10                            vlan-id 20
    ------                             ------                            ------
   !      ! .1    192.168.10.0/30   .2!      !.5    192.168.10.4/30   .6!      !
   !  R1  !---------------------------!  R2  !--------------------------!  R3  !
   !      ! fxp1.1            fxp2.1  !      ! fxp3.2            fxp4.1 !      !
    ------                             ------                            ------
lo0.1 1.1.1.1/32                 lo0.2 2.2.2.2/32                    lo.3 3.3.3.3/32
[edit]
root@iwing# show
## Last changed: 2010-02-11 01:59:36 UTC
version 8.3R2.8;
system {
    host-name iwing;
    root-authentication {
        encrypted-password "$1$bd4ySf8Q$EaiiIc24ycXAWCQHKOJCf0"; ## SECRET-DATA
    }
    services {
          ftp;
          telnet;
    }
    syslog {
        user * {
            any emergency;
    }
    file messages {
         any notice;
         authorization info;
    }
        file interactive-commands {
        interactive-commands any;
    }
  }
}
logical-routers {
R1 {
    interfaces {
       fxp1 {
          unit 1 {
             vlan-id 10;
             family inet {
                  address 192.168.10.1/30;
             }
          }
      }
      lo0 {
         unit 1 {
             family inet {
                 address 1.1.1.1/32;
             }
         }
      }
}
routing-options {
    static {
        route 192.168.10.4/30 next-hop 192.168.10.2;
       }
    }
}
R2 {
    interfaces {
          fxp2 {
            unit 1 {
               vlan-id 10;
               family inet {
                    address 192.168.10.2/30;
               }
            }
      }
fxp3 {
     unit 2 {
         vlan-id 20;
         family inet {
             address 192.168.10.5/30;
             }
      }
}
lo0 {
     unit 2 {
        family inet {
        address 2.2.2.2/32;
        }
      }
   }
}
}
R3 {
    interfaces {
        fxp4 {
          unit 1 {
             vlan-id 20;
             family inet {
                 address 192.168.10.6/30;
              }
          }
    }
lo0 {
    unit 3 {
         family inet {
             address 3.3.3.3/32;
         }
     }
  }
}
routing-options {
      static {
           route 192.168.10.0/30 next-hop 192.168.10.5;
       }
    }
 }
}
interfaces {
     fxp1 {
     vlan-tagging;
     }
     fxp2 {
     vlan-tagging;
     }
     fxp3 {
     vlan-tagging;
     }
     fxp4 {
     vlan-tagging;
     }
}
[edit]
root@iwing#
[edit]
root@iwing#
root@iwing# run show route logical-router R1
inet.0: 4 destinations, 4 routes (4 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both
1.1.1.1/32         *[Direct/0] 01:01:54
> via lo0.1
192.168.10.0/30    *[Direct/0] 01:01:54
> via fxp1.1
192.168.10.1/32    *[Local/0] 01:01:54
Local via fxp1.1
192.168.10.4/30    *[Static/5] 00:47:26
> to 192.168.10.2 via fxp1.1
[edit]
root@iwing#
[edit]
root@iwing# run show route logical-router R3
inet.0: 4 destinations, 4 routes (4 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both
3.3.3.3/32         *[Direct/0] 00:17:25
> via lo0.3
192.168.10.0/30    *[Static/5] 00:17:25
> to 192.168.10.5 via fxp4.1
192.168.10.4/30    *[Direct/0] 00:19:09
> via fxp4.1
192.168.10.6/32    *[Local/0] 00:19:09
Local via fxp4.1
[edit]
root@iwing#
[edit]
root@iwing# run ping 192.168.10.6 logical-router R1
PING 192.168.10.6 (192.168.10.6): 56 data bytes
64 bytes from 192.168.10.6: icmp_seq=0 ttl=63 time=1.465 ms
64 bytes from 192.168.10.6: icmp_seq=1 ttl=63 time=2.403 ms
64 bytes from 192.168.10.6: icmp_seq=2 ttl=63 time=0.826 ms
64 bytes from 192.168.10.6: icmp_seq=3 ttl=63 time=1.512 ms
64 bytes from 192.168.10.6: icmp_seq=4 ttl=63 time=0.983 ms
64 bytes from 192.168.10.6: icmp_seq=5 ttl=63 time=0.833 ms
64 bytes from 192.168.10.6: icmp_seq=6 ttl=63 time=1.020 ms
64 bytes from 192.168.10.6: icmp_seq=7 ttl=63 time=0.944 ms
^C
--- 192.168.10.6 ping statistics ---
8 packets transmitted, 8 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.826/1.248/2.403/0.502 ms
[edit]
root@iwing#
[edit]
root@iwing# run traceroute 192.168.10.6 logical-router R1
traceroute to 192.168.10.6 (192.168.10.6), 30 hops max, 40 byte packets
1  192.168.10.2 (192.168.10.2)  1.377 ms  0.695 ms  0.648 ms
2  192.168.10.6 (192.168.10.6)  1.385 ms  1.055 ms  0.808 ms
One Comment leave one →
  1. g4r3ng permalink
    28 February 2010 2:21 PM

    How to create multiple interface until fxp4?? please help give me tutorial??

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: