Skip to content

IS-IS Protocol

IS-IS Protocol
Topology

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!                        Level 2           !           Level 2                     !
!                                          !                                       !
!                     vlan-id 10           !          vlan-id 20                   !
!     ------                             ------                       ------       !
!    !      ! .1    192.168.10.0/30   .2!      !.5 192.168.10.4/30 .6!      !      !
!    !  R1  !---------------------------!  R2  !---------------------!  R3  !      !
!    !      ! fxp1.1             fxp2.1 !      ! fxp3.2       fxp4.1 !      !      !
!     ------                             ------                       ------       !
!lo0.1 1.1.1.1/32                  lo0.2 2.2.2.2/32               lo.3 3.3.3.3/32  !
!                                          !                                       !
!                                          !                                       !
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
(using logical router)

Configure R1
[edit logical-routers R1]
root@iwing#set interfaces lo0.1 family iso address 49.0001.1111.1111.1111.00
root@iwing#set protocols isis interfaces fxp1.1 level 1 disable
root@iwing#set protocols isis interfaces lo0.1 passive
root@iwing#set interfaces fxp1.1 family iso 

Configure R2
[edit logical-routers R2]
root@iwing#set interfaces lo0.2 family iso address 49.0001.2222.2222.2222.00
root@iwing#set protocols isis interfaces fxp2.1 level 1 disable
root@iwing#set protocols isis interfaces fxp3.2 level 1 disable
root@iwing#set protocols isis interfaces lo0.2 passive
root@iwing#set interfaces fxp2.1 family iso 
root@iwing#set interfaces fxp3.2 family iso

Configure R3
[edit logical-routers R3]
root@iwing#set interfaces lo0.3 family iso address 49.0001.3333.3333.3333.00
root@iwing#set protocols isis interfaces fxp4.1 level 1 disable
root@iwing#set protocols isis interfaces lo0.3 passive
root@iwing#set interfaces fxp4.1 family iso 

How to Check
[edit]
root@iwing# run show route protocol isis logical-router R1
inet.0: 6 destinations, 6 routes (6 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

2.2.2.2/32         *[IS-IS/18] 00:11:32, metric 10
                   > to 192.168.10.2 via fxp1.1
3.3.3.3/32         *[IS-IS/18] 00:11:32, metric 20
                   > to 192.168.10.2 via fxp1.1
192.168.10.4/30    *[IS-IS/18] 00:11:32, metric 20
                   > to 192.168.10.2 via fxp1.1

iso.0: 1 destinations, 1 routes (1 active, 0 holddown, 0 hidden)

[edit]
root@iwing# run show route protocol isis logical-router R2
inet.0: 7 destinations, 7 routes (7 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

1.1.1.1/32         *[IS-IS/18] 00:11:36, metric 10
                   > to 192.168.10.1 via fxp2.1
3.3.3.3/32         *[IS-IS/18] 00:11:36, metric 10
                  > to 192.168.10.6 via fxp3.2
iso.0: 1 destinations, 1 routes (1 active, 0 holddown, 0 hidden)

[edit]
root@iwing# run show route protocol isis logical-router R3
inet.0: 6 destinations, 6 routes (6 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

1.1.1.1/32         *[IS-IS/18] 00:11:39, metric 20
                   > to 192.168.10.5 via fxp4.1
2.2.2.2/32         *[IS-IS/18] 00:11:39, metric 10
                   > to 192.168.10.5 via fxp4.1
192.168.10.0/30    *[IS-IS/18] 00:11:39, metric 20
                   > to 192.168.10.5 via fxp4.1
iso.0: 1 destinations, 1 routes (1 active, 0 holddown, 0 hidden)

root@iwing# run show isis interface logical-router R1
IS-IS interface database:
Interface             L CirID Level 1 DR        Level 2 DR        L1/L2 Metric
fxp1.1                2   0x1 Disabled          iwing-R2.02            10/10
lo0.1                 0   0x1 Passive           Passive                 0/0

[edit]
root@iwing# run show isis interface logical-router R2
IS-IS interface database:
Interface             L CirID Level 1 DR        Level 2 DR        L1/L2 Metric
fxp2.1                2   0x2 Disabled          iwing-R2.02            10/10
fxp3.2                2   0x1 Disabled          iwing-R3.02            10/10
lo0.2                 0   0x1 Passive           Passive                 0/0

[edit]
root@iwing# run show isis interface logical-router R3
IS-IS interface database:
Interface             L CirID Level 1 DR        Level 2 DR        L1/L2 Metric
fxp4.1                2   0x2 Disabled          iwing-R3.02            10/10
lo0.3                 0   0x1 Passive           Passive                 0/0

[edit]
root@iwing# run show isis adjacency logical-router R1
Interface             System         L State        Hold (secs) SNPA
fxp1.1                iwing-R2       2  Up                    7  0:aa:0:0:1:4

[edit]
root@iwing# run show isis adjacency logical-router R2
Interface             System         L State        Hold (secs) SNPA
fxp2.1                iwing-R1       2  Up                   22  0:aa:0:0:1:3
fxp3.2                iwing-R3       2  Up                    6  0:aa:0:0:1:6

[edit]
root@iwing# run show isis adjacency logical-router R3
Interface             System         L State        Hold (secs) SNPA
fxp4.1                iwing-R2       2  Up                   19  0:aa:0:0:1:5

[edit]
root@iwing# run ping 3.3.3.3 logical-router R1
PING 3.3.3.3 (3.3.3.3): 56 data bytes
64 bytes from 3.3.3.3: icmp_seq=0 ttl=63 time=4.348 ms
64 bytes from 3.3.3.3: icmp_seq=1 ttl=63 time=2.633 ms
64 bytes from 3.3.3.3: icmp_seq=2 ttl=63 time=0.788 ms
64 bytes from 3.3.3.3: icmp_seq=3 ttl=63 time=0.771 ms
64 bytes from 3.3.3.3: icmp_seq=4 ttl=63 time=0.763 ms
64 bytes from 3.3.3.3: icmp_seq=5 ttl=63 time=0.767 ms
^C
--- 3.3.3.3 ping statistics ---
6 packets transmitted, 6 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.763/1.678/4.348/1.374 ms

[edit]
root@iwing# run traceroute 3.3.3.3 logical-router R1
traceroute to 3.3.3.3 (3.3.3.3), 30 hops max, 40 byte packets
 1  192.168.10.2 (192.168.10.2)  2.209 ms  0.665 ms  0.582 ms
 2  3.3.3.3 (3.3.3.3)  1.857 ms  0.721 ms  1.223 ms

Final Configuration
root@iwing# show
## Last changed: 2010-02-12 06:07:11 UTC
version 8.3R2.8;
system {
    host-name iwing;
    root-authentication {
         encrypted-password "$1$bd4ySf8Q$EaiiIc24ycXAWCQHKOJCf0"; ## SECRET-DATA
 }
 services {
      ftp;
      telnet;
 }
 syslog {
      user * {
           any emergency;
      }
      file messages {
          any notice;
          authorization info;
      }
      file interactive-commands {
          interactive-commands any;
      }
   }
}
logical-routers {
     R1 {
        interfaces {
            fxp1 {
               unit 1 {
                  vlan-id 10;
                  family inet {
                      address 192.168.10.1/30;
               }
               family iso;
           }
     }
     lo0 {
        unit 1 {
            family inet {
                address 1.1.1.1/32;
            }
            family iso {
                 address 49.0001.1111.1111.1111.00;
            }
         }
     }
 }
 protocols {
     isis {
         interface fxp1.1 {
               level 1 disable;
         }
         interface lo0.1 {
              passive;
         }
       }
    }
 }
 R2 {
     interfaces {
         fxp2 {
            unit 1 {
               vlan-id 10;
               family inet {
                   address 192.168.10.2/30;
               }
               family iso;
            }
        }
        fxp3 {
          unit 2 {
              vlan-id 20;
              family inet {
                   address 192.168.10.5/30;
              }
              family iso;
              }
        }
        lo0 {
           unit 2 {
               family inet {
                    address 2.2.2.2/32;
               }
               family iso {
                    address 49.0001.2222.2222.2222.00;
               }
           }
      }
 }
 protocols {
      isis {
          interface fxp2.1 {
              level 1 disable;
          }
          interface fxp3.2 {
              level 1 disable;
          }
          interface lo0.2 {
              passive;
          }
        }
     }
 }
 R3 {
    interfaces {
        fxp4 {
            unit 1 {
                vlan-id 20;
                family inet {
                     address 192.168.10.6/30;
                }
                family iso;
           }
       }
       lo0 {
          unit 3 {
              family inet {
                   address 3.3.3.3/32;
             }
              family iso {
                  address 49.0001.3333.3333.3333.00;
             }
         }
      }
   }
    protocols {
         isis {
             interface fxp4.1 {
                level 1 disable;
              }
             interface lo0.3 {
                 passive;
              }
          }
      }
    }
}
interfaces {
   fxp1 {
       vlan-tagging;
   }
   fxp2 {
       vlan-tagging;
   }
   fxp3 {
       vlan-tagging;
   }
   fxp4 {
       vlan-tagging;
   }
}
[edit]
root@iwing#
No comments yet

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: