Skip to content

hda: INVALID GEOMETRY: 64 PHYSICAL HEADS? Buffer I/O error on device hda, logical block 0 [solved]

Suatu ketika server mengalami hang tiba-tiba ketika direstart tidak mau boot secara normal dan mengeluarkan error seperti berikut ini:

1

Berhubung server ini bukan merupakan server critical maka bisa diotak-atik untuk dicari akar permasalahannya, akan tetapi sialnya aplikasi server mau dipakai untuk pelatihan diesok harinya, dengan berat hati server harus disolved malam hari ini juga. Karena kondisi kalut dan deadline yang mengharuskan server dapat kembali beroperasi diesok hari maka saya memutuskan untuk mengambil langkah yang saya anggap perlu:

1. Melihat log melalui ILO (Tidak ditemukan log yang aneh)
2. Reboot server, masuk mode single mode lalu force untuk melakukan fsck

2

Alhamdullilah server dapat masuk ke single mode dan dapat saya force untuk melakukan fsck, kemudian saya restart ulang server tersebut.
3. Booting dengan beberapa error yang muncul

3
4. Healthy check tidak bisa dilakukan, cd/dvd-room not found. Tadinya saya mau coba menggunakan software bawaan h/w server untuk mengecek kondisi server, tapi anehnya cd/dvd room tidak mau dieject dan mengeluarkan pesan error cd/dvd-room not found. Saya berpikiran bahwa error hda berhubungan dengan Hardisk maka saya lanjut ke langkah selanjutnya.
5. Berhubung server menggunakan RAID-1, saya cabut salah satu HDD existing Slot 1 ganti dengan HDD backup A, tunggu sampai synchronized,  reboot dan force melakukan repair disk (fsck command)
6. Setelah server direstart dan “Buffer I/O on device hda, logical block 0” error masih terjadi

4
7. Cabut salah satu HDD existing Slot 2 ganti dengan HDD backup B, tunggu sampai synchronized, reboot dan force melakukan repair disk (fsck command)
8. Setelah Server direstart “Buffer I/O on device hda, logical block 0” error masih terjadi
9.  Nah setelah langkah pada point 8 dilakukan “Buffer I/O on device hda, logical block 0” error masih terjadi, mengapa masih terjadi error? padahal kedua HDD sudah menggunakan HDD yang baru!
10. Kemudian HDD Slot 1 dan Slot 2 dari server lama saya masukkan ke server lain untuk keperluan testing.
11. server booting dengan normal, “Buffer I/O on device hda, logical block 0” tidak terjadi …

5

13. Kesimpulan sementara bahwa HDD yang dibawa dari server lama tidak ada masalah sama sekali
14. Setelah dilanda kebingungan sesaat maka dirasa saatnya perlu bertanya kepada paman google dan setelah beberapa page tidak ditemukan jawaban yang dapat membantu, akhirnya didapat suatu link yang mengalami kasus yang sama dengan yang saya alami. Percaya atau tidak, dilink tersebut dinyatakan permasalahan timbul dari H/W cd/dvd room yang bermasalah. Kemudian saya coba untuk mengganti cd/dvd-room dan viola server booting dengan normal …

6

7

Akhirnya saya dapat meninggalkan ruang server dengan wajah tersenyum.

No comments yet

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: