Skip to content

Belajar Simulasi CISCO MPLS-L3VPN (PE-CE BGP)

Topology yang saya gunakan adalah seperti gambar dibawah ini:


Konfigurasi IP addressnya adalah sebagai berikut:


Dan Langkah-langkahnya adalah sebagai berikut:

Pertama:
konfigure semua interface (PE1-Core-PE2)

---------------core----------------------
!
interface Loopback0
 ip address 192.168.100.1 255.255.255.255
!
interface GigabitEthernet1/0
 ip address 192.168.10.10 255.255.255.252
!
interface GigabitEthernet2/0
 ip address 192.168.10.13 255.255.255.252
-----------------------------------------

---------------PE1-----------------------
interface Loopback0
 ip address 192.168.100.2 255.255.255.255
!
interface GigabitEthernet1/0
 ip address 192.168.10.9 255.255.255.252
-----------------------------------------

---------------PE2-----------------------
interface Loopback0
 ip address 192.168.100.3 255.255.255.255
!
interface GigabitEthernet1/0
 ip address 192.168.10.14 255.255.255.252
-----------------------------------------

Kedua:Aktifkan Dynamic Routing 

---------------core----------------------
router ospf 1
 network 192.168.10.0 0.0.0.255 area 0
 network 192.168.100.1 0.0.0.0 area 0
-----------------------------------------

---------------PE1-----------------------
router ospf 1
 network 192.168.10.0 0.0.0.255 area 0
 network 192.168.100.2 0.0.0.0 area 0
-----------------------------------------

---------------PE2-----------------------
router ospf 1
 network 192.168.10.0 0.0.0.255 area 0
 network 192.168.100.3 0.0.0.0 area 0
-----------------------------------------
untuk pengecekan : ketikan show ip route

core#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

 192.168.10.0/30 is subnetted, 2 subnets
C       192.168.10.8 is directly connected, GigabitEthernet1/0
C       192.168.10.12 is directly connected, GigabitEthernet2/0
 192.168.100.0/32 is subnetted, 3 subnets
C       192.168.100.1 is directly connected, Loopback0
O       192.168.100.2 [110/2] via 192.168.10.9, 00:03:03, GigabitEthernet1/0
O       192.168.100.3 [110/2] via 192.168.10.14, 00:03:13, GigabitEthernet2/0
core#

PE1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

 192.168.10.0/30 is subnetted, 2 subnets
C       192.168.10.8 is directly connected, GigabitEthernet1/0
O       192.168.10.12 [110/2] via 192.168.10.10, 00:03:28, GigabitEthernet1/0
 192.168.100.0/32 is subnetted, 3 subnets
O       192.168.100.1 [110/2] via 192.168.10.10, 00:03:28, GigabitEthernet1/0
C       192.168.100.2 is directly connected, Loopback0
O       192.168.100.3 [110/3] via 192.168.10.10, 00:03:28, GigabitEthernet1/0
PE1#

PE2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

 192.168.10.0/30 is subnetted, 2 subnets
O       192.168.10.8 [110/2] via 192.168.10.13, 00:03:36, GigabitEthernet1/0
C       192.168.10.12 is directly connected, GigabitEthernet1/0
 192.168.100.0/32 is subnetted, 3 subnets
O       192.168.100.1 [110/2] via 192.168.10.13, 00:03:36, GigabitEthernet1/0
O       192.168.100.2 [110/3] via 192.168.10.13, 00:03:36, GigabitEthernet1/0
C       192.168.100.3 is directly connected, Loopback0
PE2#

Ketiga:Aktifkan BGP

---------------PE1-----------------------
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.168.100.3 remote-as 100
 neighbor 192.168.100.3 update-source Loopback0
 no auto-summary
-----------------------------------------

---------------PE2-----------------------
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.168.100.2 remote-as 100
 neighbor 192.168.100.2 update-source Loopback0
 no auto-summary
-----------------------------------------
untuk pengecekan : ketikan show ip bgp sum

PE1#sh ip bgp summary
BGP router identifier 192.168.100.2, local AS number 100
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
192.168.100.3   4   100       9       9        1    0    0 00:03:26        0
PE1#

PE2#sh ip bgp summary
BGP router identifier 192.168.100.3, local AS number 100
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
192.168.100.2   4   100       9       9        1    0    0 00:03:31        0
PE2#

Keempat:Aktifkan MPLS
---------------core----------------------
ip cef
!
mpls label protocol ldp
!
interface GigabitEthernet1/0
 ip address 192.168.10.10 255.255.255.252
 mpls ip
!
interface GigabitEthernet2/0
 ip address 192.168.10.13 255.255.255.252
 mpls ip
-----------------------------------------

---------------PE1-----------------------
ip cef
!
mpls label protocol ldp
!
mpls ldp router-id Loopback0 force
!
interface GigabitEthernet1/0
 ip address 192.168.10.9 255.255.255.252
 mpls ip
-----------------------------------------

---------------PE2-----------------------
ip cef
!
mpls label protocol ldp
!
mpls ldp router-id Loopback0 force
!
interface GigabitEthernet1/0
 ip address 192.168.10.14 255.255.255.252
 mpls ip
-----------------------------------------
untuk pengecekan : ketikan show mpls ldp neighbor

core#show mpls ldp neighbor
 Peer LDP Ident: 192.168.100.3:0; Local LDP Ident 192.168.100.1:0
 TCP connection: 192.168.100.3.30066 - 192.168.100.1.646
 State: Oper; Msgs sent/rcvd: 12/12; Downstream
 Up time: 00:03:57
 LDP discovery sources:
 GigabitEthernet2/0, Src IP addr: 192.168.10.14
 Addresses bound to peer LDP Ident:
 192.168.10.14   192.168.100.3
 Peer LDP Ident: 192.168.100.2:0; Local LDP Ident 192.168.100.1:0
 TCP connection: 192.168.100.2.41604 - 192.168.100.1.646
 State: Oper; Msgs sent/rcvd: 12/12; Downstream
 Up time: 00:03:48
 LDP discovery sources:
 GigabitEthernet1/0, Src IP addr: 192.168.10.9
 Addresses bound to peer LDP Ident:
 192.168.10.9    192.168.100.2
core#

PE1#sh mpls ldp neighbor
 Peer LDP Ident: 192.168.100.1:0; Local LDP Ident 192.168.100.2:0
 TCP connection: 192.168.100.1.646 - 192.168.100.2.41604
 State: Oper; Msgs sent/rcvd: 12/12; Downstream
 Up time: 00:03:55
 LDP discovery sources:
 GigabitEthernet1/0, Src IP addr: 192.168.10.10
 Addresses bound to peer LDP Ident:
 192.168.10.10   192.168.100.1   192.168.10.13
PE1#

PE2#sh mpls ldp neighbor
 Peer LDP Ident: 192.168.100.1:0; Local LDP Ident 192.168.100.3:0
 TCP connection: 192.168.100.1.646 - 192.168.100.3.30066
 State: Oper; Msgs sent/rcvd: 12/12; Downstream
 Up time: 00:04:10
 LDP discovery sources:
 GigabitEthernet1/0, Src IP addr: 192.168.10.13
 Addresses bound to peer LDP Ident:
 192.168.10.10   192.168.100.1   192.168.10.13
PE2#

Kelima:Buat Router Virtual

---------------PE1-----------------------
ip vrf cnc1
 rd 100:1
 route-target export 100:1
 route-target import 100:1
!
interface GigabitEthernet2/0
 ip vrf forwarding cnc1
 ip address 192.168.10.2 255.255.255.252
-----------------------------------------
---------------PE2-----------------------
ip vrf cnc1
 rd 100:1
 route-target export 100:1
 route-target import 100:1
!
interface GigabitEthernet2/0
 ip vrf forwarding cnc1
 ip address 192.168.10.17 255.255.255.252

-----------------------------------------
untuk pengecekan : ketikan show ip vrf (name)

Keenam: Menambahkan Routing DiRouter Virtual
dan Aktifkan MP-BGP

---------------PE1-----------------------
router bgp 100
 !
 address-family ipv4
 neighbor 192.168.100.3 activate
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 192.168.100.3 activate
 neighbor 192.168.100.3 send-community both
 exit-address-family
 !
 address-family ipv4 vrf cnc1
 neighbor 192.168.10.1 remote-as 65001
 neighbor 192.168.10.1 activate
 neighbor 192.168.10.1 as-override
 no synchronization
 exit-address-family
!
-----------------------------------------
---------------PE2-----------------------
router bgp 100
 !
 address-family ipv4
 neighbor 192.168.100.2 activate
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 192.168.100.2 activate
 neighbor 192.168.100.2 send-community both
 exit-address-family
 !
 address-family ipv4 vrf cnc1
 neighbor 192.168.10.18 remote-as 65001
 neighbor 192.168.10.18 activate
 neighbor 192.168.10.18 as-override
 no synchronization
 exit-address-family
!
-----------------------------------------
nb:jika custumer memiliki ASN yang berbeda,
perintah neighbor [] as-override tidak perlu ditambahkan

untuk pengecekan : ketikan show ip route vrf (name)

PE1#show ip route vrf cnc1

Routing Table: cnc1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

 192.168.10.0/30 is subnetted, 2 subnets
C       192.168.10.0 is directly connected, GigabitEthernet2/0
B       192.168.10.16 [200/0] via 192.168.100.3, 00:05:58
 10.0.0.0/32 is subnetted, 2 subnets
B       10.14.200.1 [20/0] via 192.168.10.1, 00:06:46
B       10.14.200.2 [200/0] via 192.168.100.3, 00:05:58
PE1#

PE2#sh ip route vrf cnc1

Routing Table: cnc1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

 192.168.10.0/30 is subnetted, 2 subnets
B       192.168.10.0 [200/0] via 192.168.100.2, 00:06:18
C       192.168.10.16 is directly connected, GigabitEthernet2/0
 10.0.0.0/32 is subnetted, 2 subnets
B       10.14.200.1 [200/0] via 192.168.100.2, 00:06:18
B       10.14.200.2 [20/0] via 192.168.10.18, 00:06:50
PE2#

Ketujuh: Mengaktifkan CE dan Pengujian End-to-end

---------------cnc1_a--------------------
cnc1_a#sh run
!
ip cef
!
interface Loopback0
 ip address 10.14.200.1 255.255.255.255
!
interface GigabitEthernet1/0
 ip address 192.168.10.1 255.255.255.252
 negotiation auto
!
router bgp 65001
 no synchronization
 bgp log-neighbor-changes
 network 10.14.200.1 mask 255.255.255.255
 neighbor 192.168.10.2 remote-as 100
 no auto-summary
!
line con 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 password 7 xxxx
 login
!
end

cnc1_a#

-----------------------------------------

--------------cnc1_b---------------------
cnc1_b#sh run
!
ip cef
!
interface Loopback0
 ip address 10.14.200.2 255.255.255.255
!
interface GigabitEthernet1/0
 ip address 192.168.10.18 255.255.255.252
 negotiation auto
!
router bgp 65001
 no synchronization
 bgp log-neighbor-changes
 network 10.14.200.2 mask 255.255.255.255
 neighbor 192.168.10.17 remote-as 100
 no auto-summary
!
line con 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 password 7 xxxx
 login
!
end

cnc1_b#

cnc1_a#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

 192.168.10.0/30 is subnetted, 2 subnets
C       192.168.10.0 is directly connected, GigabitEthernet1/0
B       192.168.10.16 [20/0] via 192.168.10.2, 00:06:54
 10.0.0.0/32 is subnetted, 2 subnets
C       10.14.200.1 is directly connected, Loopback0
B       10.14.200.2 [20/0] via 192.168.10.2, 00:06:54
cnc1_a#

cnc1_b#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

 192.168.10.0/30 is subnetted, 2 subnets
B       192.168.10.0 [20/0] via 192.168.10.17, 00:07:10
C       192.168.10.16 is directly connected, GigabitEthernet1/0
 10.0.0.0/32 is subnetted, 2 subnets
B       10.14.200.1 [20/0] via 192.168.10.17, 00:07:10
C       10.14.200.2 is directly connected, Loopback0
cnc1_b#

-----------------------------------------
untuk pengecekan : pergunakan perintah ping,traceroute dan telnet

cnc1_a#pi
Protocol [ip]:
Target IP address: 10.14.200.2
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.14.200.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 252/375/676 ms
cnc1_a#
cnc1_a#traceroute 10.14.200.2

Type escape sequence to abort.
Tracing the route to 10.14.200.2

 1 192.168.10.2 [AS 100] 100 msec 768 msec 68 msec
 2 192.168.10.10 [MPLS: Labels 16/19 Exp 0] 308 msec 388 msec 356 msec
 3 192.168.10.17 [AS 100] [MPLS: Label 19 Exp 0] 280 msec 268 msec 260 msec
 4 192.168.10.18 [AS 100] 352 msec 316 msec *
cnc1_a#telnet 10.14.200.2
Trying 10.14.200.2 ... Open

User Access Verification

Password:
cnc1_b>

cnc1_b#pi
Protocol [ip]:
Target IP address: 10.14.200.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.14.200.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 284/372/548 ms
cnc1_b#
cnc1_b#traceroute 10.14.200.1

Type escape sequence to abort.
Tracing the route to 10.14.200.1

 1 192.168.10.17 [AS 100] 100 msec 76 msec 92 msec
 2 192.168.10.13 [MPLS: Labels 17/16 Exp 0] 312 msec 340 msec 260 msec
 3 192.168.10.2 [AS 100] [MPLS: Label 16 Exp 0] 236 msec 232 msec 332 msec
 4 192.168.10.1 [AS 100] 1148 msec 700 msec *
cnc1_b#telnet 10.14.200.1
Trying 10.14.200.1 ... Open

User Access Verification

Password:
cnc1_a>

"------------Sekian dulu, semoga bermanfaat------------------"

Ref: 

[1]Rasyid,Rafdian.EXPERIMENT Cisco MPLS-L3VPN Dengan GNS3,
URL http://www.ilmukomputer.com,(Februari 2010)   
[2]http://www.ccie18473.net
[3]Cisco IOS Multiprotocol Label Switching Configuration Guide,
URL:http://www.cisco.com, (Februari 2010)
One Comment leave one →
  1. Khusni Nadzif permalink
    9 September 2016 3:39 AM

    Ninggalin jejak dulu buat bahan belajar weekend🙂

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: