Skip to content

Belajar Mengkonfigurasi MPLS TE (Unequal-Cost Load Sharing)

13 August 2010
tags: ,

—————————————————————————
Purpose: MPLS TE Unequal-Cost Load Sharing.

Comments:
Traffic from R1(cnc1) to R5(cnc5) uses paths through
R2(cnc2),R3(cnc3) and R4(cnc4) with a 1:2:3 ratio.
—————————————————————————
Topology yang digunakan adalah sebagai berikut:
—————————————————————————

—————————————————————————
[1]. Tunnel 1 Explicit-Path R1-R4-R5 tunnel MPLS Trffic-Eng Load share 10
[2]. Tunnel 2 Explicit-Path R1-R3-R5 tunnel MPLS Trffic-Eng Load share 20
[3]. Tunnel 3 Explicit-Path R1-R4-R5 tunnel MPLS Trffic-Eng Load share 30
—————————————————————————
cnc1#sh ip route 5.5.5.5
Routing entry for 5.5.5.5/32
Known via “ospf 1”, distance 110, metric 129, type intra area
Last update from 5.5.5.5 on Tunnel1, 00:51:51 ago
Routing Descriptor Blocks:
* 5.5.5.5, from 5.5.5.5, 00:51:51 ago, via Tunnel1
Route metric is 129, traffic share count is 1
5.5.5.5, from 5.5.5.5, 00:51:51 ago, via Tunnel2
Route metric is 129, traffic share count is 2
5.5.5.5, from 5.5.5.5, 00:51:51 ago, via Tunnel3
Route metric is 129, traffic share count is 3

cnc1#
—————————————————————————
cnc1#show mpls traffic-eng tunnels tunnel 1

Name: cnc1_t1                             (Tunnel1) Destination: 5.5.5.5
Status:
Admin: up         Oper: up     Path: valid       Signalling: connected
path option 1, type explicit R1-R4-R5 (Basis for Setup, path weight 128)

Config Parameters:
Bandwidth: 0        kbps (Global)  Priority: 7  7   Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute:  enabled   LockDown: disabled  Loadshare: 10
auto-bw: disabled
Active Path Option Parameters:
State: explicit path option 1 is active
BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled

InLabel  :  –
OutLabel : Serial3/0, 16
RSVP Signalling Info:
Src 1.1.1.1, Dst 5.5.5.5, Tun_Id 1, Tun_Instance 5
RSVP Path Info:
My Address: 192.168.10.9
Explicit Route: 192.168.10.10 192.168.10.18 5.5.5.5
Record   Route:   NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record   Route:   NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
Shortest Unconstrained Path Info:
Path Weight: 128 (TE)
Explicit Route: 192.168.10.10 192.168.10.18 5.5.5.5
History:
Tunnel:
Time since created: 1 hours, 32 minutes
Time since path change: 1 hours, 23 minutes
Number of LSP IDs (Tun_Instances) used: 5
Current LSP:
Uptime: 1 hours, 23 minutes
Selection: reoptimization
Prior LSP:
ID: path option 1 [4]
Removal Trigger: configuration changed
—————————————————————————
cnc1#show mpls traffic-eng tunnels tunnel 2

Name: cnc1_t2                             (Tunnel2) Destination: 5.5.5.5
Status:
Admin: up         Oper: up     Path: valid       Signalling: connected
path option 1, type explicit R1-R3-R5 (Basis for Setup, path weight 128)

Config Parameters:
Bandwidth: 0        kbps (Global)  Priority: 7  7   Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute:  enabled   LockDown: disabled  Loadshare: 20
auto-bw: disabled
Active Path Option Parameters:
State: explicit path option 1 is active
BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled

InLabel  :  –
OutLabel : Serial3/1, 29
RSVP Signalling Info:
Src 1.1.1.1, Dst 5.5.5.5, Tun_Id 2, Tun_Instance 5
RSVP Path Info:
My Address: 192.168.10.5
Explicit Route: 192.168.10.6 192.168.10.22 5.5.5.5
Record   Route:   NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record   Route:   NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
Shortest Unconstrained Path Info:
Path Weight: 128 (TE)
Explicit Route: 192.168.10.10 192.168.10.18 5.5.5.5
History:
Tunnel:
Time since created: 1 hours, 29 minutes
Time since path change: 1 hours, 22 minutes
Number of LSP IDs (Tun_Instances) used: 5
Current LSP:
Uptime: 1 hours, 22 minutes
Selection: reoptimization
Prior LSP:
ID: path option 1 [4]
Removal Trigger: configuration changed
—————————————————————————
cnc1#show mpls traffic-eng tunnels tunnel 3

Name: cnc1_t3                             (Tunnel3) Destination: 5.5.5.5
Status:
Admin: up         Oper: up     Path: valid       Signalling: connected
path option 1, type explicit R1-R2-R5 (Basis for Setup, path weight 128)

Config Parameters:
Bandwidth: 0        kbps (Global)  Priority: 7  7   Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute:  enabled   LockDown: disabled  Loadshare: 30
auto-bw: disabled
Active Path Option Parameters:
State: explicit path option 1 is active
BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled

InLabel  :  –
OutLabel : Serial3/2, 30
RSVP Signalling Info:
Src 1.1.1.1, Dst 5.5.5.5, Tun_Id 3, Tun_Instance 4
RSVP Path Info:
My Address: 192.168.10.1
Explicit Route: 192.168.10.2 192.168.10.26 5.5.5.5
Record   Route:   NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record   Route:   NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
Shortest Unconstrained Path Info:
Path Weight: 128 (TE)
Explicit Route: 192.168.10.10 192.168.10.18 5.5.5.5
History:
Tunnel:
Time since created: 1 hours, 27 minutes
Time since path change: 1 hours, 21 minutes
Number of LSP IDs (Tun_Instances) used: 4
Current LSP:
Uptime: 1 hours, 21 minutes
Selection: reoptimization
Prior LSP:
ID: path option 1 [3]
Removal Trigger: configuration changed
cnc1#
—————————————————————————
cnc1#sh mpls traffic-eng link-management summary
System Information::
Links Count:          3
Flooding System:      enabled
IGP Area ID::  ospf 1  area 0
Flooding Protocol:    OSPF
Flooding Status:      data flooded
Periodic Flooding:    enabled (every 180 seconds)
Flooded Links:        3
IGP System ID:        1.1.1.1
MPLS TE Router ID:    1.1.1.1
Neighbors:            3
Link ID::  Se3/0 (192.168.10.9)
Local Intfc ID:         6
Link Status:
SRLGs:                None
Intfc Switching Capability Descriptors:
Default:           Intfc Switching Cap psc1, Encoding packet
Link Label Type:      Packet
Physical Bandwidth:   1544 kbits/sec
Max Res Global BW:    1158 kbits/sec (reserved: 0% in, 0% out)
Max Res Sub BW:       0 kbits/sec (reserved: 100% in, 100% out)
MPLS TE Link State:   MPLS TE on, RSVP on, admin-up, flooded, allocated
Inbound Admission:    allow-all
Outbound Admission:   allow-if-room
Admin. Weight:        64 (IGP)
IGP Neighbor Count:   1
Link ID::  Se3/1 (192.168.10.5)
Local Intfc ID:         7
Link Status:
SRLGs:                None
Intfc Switching Capability Descriptors:
Default:           Intfc Switching Cap psc1, Encoding packet
Link Label Type:      Packet
Physical Bandwidth:   1544 kbits/sec
Max Res Global BW:    1158 kbits/sec (reserved: 0% in, 0% out)
Max Res Sub BW:       0 kbits/sec (reserved: 100% in, 100% out)
MPLS TE Link State:   MPLS TE on, RSVP on, admin-up, flooded, allocated
Inbound Admission:    allow-all
Outbound Admission:   allow-if-room
Admin. Weight:        64 (IGP)
IGP Neighbor Count:   1
Link ID::  Se3/2 (192.168.10.1)
Local Intfc ID:         8
Link Status:
SRLGs:                None
Intfc Switching Capability Descriptors:
Default:           Intfc Switching Cap psc1, Encoding packet
Link Label Type:      Packet
Physical Bandwidth:   1544 kbits/sec
Max Res Global BW:    1158 kbits/sec (reserved: 0% in, 0% out)
Max Res Sub BW:       0 kbits/sec (reserved: 100% in, 100% out)
MPLS TE Link State:   MPLS TE on, RSVP on, admin-up, flooded, allocated
Inbound Admission:    allow-all
Outbound Admission:   allow-if-room
Admin. Weight:        64 (IGP)
IGP Neighbor Count:   1
cnc1#

—————————————————————————
Contoh konfigurasi di router cnc1:
—————————————————————————
cnc1#
!
hostname cnc1
!
ip cef
—————————————————————————
mpls traffic-eng tunnels
mpls traffic-eng reoptimize timers frequency 60
no mpls traffic-eng auto-bw timers frequency 0
mpls label protocol ldp
—————————————————————————
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Tunnel1
ip unnumbered Loopback0
no clns route-cache
tunnel destination 5.5.5.5
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng path-option 1 explicit name R1-R4-R5
tunnel mpls traffic-eng load-share 10
no routing dynamic
!
interface Tunnel2
ip unnumbered Loopback0
tunnel destination 5.5.5.5
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng path-option 1 explicit name R1-R3-R5
tunnel mpls traffic-eng load-share 20
no routing dynamic
!
interface Tunnel3
ip unnumbered Loopback0
tunnel destination 5.5.5.5
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng path-option 1 explicit name R1-R2-R5
tunnel mpls traffic-eng load-share 30
no routing dynamic
—————————————————————————
!
interface FastEthernet0/0
ip address 10.14.100.1 255.255.255.252
duplex half
mpls ip
!
interface Serial3/0
ip address 192.168.10.9 255.255.255.252
mpls traffic-eng tunnels
mpls ip
serial restart-delay 0
ip rsvp bandwidth
!
interface Serial3/1
ip address 192.168.10.5 255.255.255.252
mpls traffic-eng tunnels
mpls ip
serial restart-delay 0
ip rsvp bandwidth
!
interface Serial3/2
ip address 192.168.10.1 255.255.255.252
mpls traffic-eng tunnels
mpls ip
serial restart-delay 0
ip rsvp bandwidth
!
—————————————————————————
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
router-id 1.1.1.1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 10.14.100.0 0.0.0.3 area 0
network 192.168.10.0 0.0.0.3 area 0
network 192.168.10.4 0.0.0.3 area 0
network 192.168.10.8 0.0.0.3 area 0
—————————————————————————
ip explicit-path name R1-R4-R5 enable
next-address 192.168.10.10
next-address 192.168.10.18
next-address 5.5.5.5
!
ip explicit-path name R1-R3-R5 enable
next-address 192.168.10.6
next-address 192.168.10.22
next-address 5.5.5.5
!
ip explicit-path name R1-R2-R5 enable
next-address 192.168.10.2
next-address 192.168.10.26
next-address 5.5.5.5
—————————————————————————
ref:
[1]. http://www.ccie18473.net

No comments yet

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: