Skip to content

Belajar mengkonfigurasi OSPF over NBMA POINT TO MULTIPOINT mode (PtM)

15 June 2010
Belajar mengkonfigurasi OSPF over NBMA POINT TO MULTIPOINT mode (PtM).
Topology yang digunakan adalah sebagai berikut:
------------------------------------------------
                      lo 100 192.168.30.0/24
                              +------+               
                              !      !                    
                              !(cnc2)!
                              !      !                   
                              +------+   
                                 / s1/0
        dlci 101 ---> dlci 202  /
                               /    
 lo 100 192.168.20.0/24       /       
 +------+                +------+
 !      !s1/0            !      !        
 !(cnc1)!----------------! FRS  !
 !      !                !      !        
 +------+                +------+
                             \
                              \       
       dlci 102 ---> dlci 203  \
                                \
                                 \s1/0
                              +------+               
                              !      !                    
                              !(cnc3)!
                              !      !                   
                              +------+  
                       lo 100 192.168.40.0/24

S1/0 cnc1 192.168.10.1/24
S1/0 cnc2 192.168.10.2/24
S1/0 cnc3 192.168.10.3/24
------------------------------------------------
Sebelumnya kita review sedikit mengenai sifat OSPF
PtM ini, sifat-sifatnya adalah :

-Requires single subnet
-no DR/BDR elected
-Neighbours automatically form
ok, langkah-langkahnya adalah sebagai berikut:
------------------------------------------------
1. Konfigurasi addressing
------------------------------------------------
cnc1#sh run interface s1/0
Building configuration...

Current configuration : 281 bytes
!
interface Serial1/0
 ip address 192.168.10.1 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 no arp frame-relay
 frame-relay map ip 192.168.10.2 101 broadcast
 frame-relay map ip 192.168.10.3 102 broadcast
 no frame-relay inverse-arp
end

cnc1#

cnc2#sh run int s1/0
Building configuration...

Current configuration : 279 bytes
!
interface Serial1/0
 ip address 192.168.10.2 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 no arp frame-relay
 frame-relay map ip 192.168.10.1 202 broadcast
 no frame-relay inverse-arp
end

cnc2#

cnc3#sh run int s1/0
Building configuration...

Current configuration : 279 bytes
!
interface Serial1/0
 ip address 192.168.10.3 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 no arp frame-relay
 frame-relay map ip 192.168.10.1 203 broadcast
 no frame-relay inverse-arp
end

cnc3#
------------------------------------------------
2.how to check 1 (sh frame-relay map)
------------------------------------------------
cnc1#sh frame-relay map
Serial1/0 (up): ip 192.168.10.2 dlci 101(0x65,0x1850), static,
 broadcast,
 CISCO, status defined, active
Serial1/0 (up): ip 192.168.10.3 dlci 102(0x66,0x1860), static,
 broadcast,
 CISCO, status defined, active
cnc1#

cnc2#sh frame-relay map
Serial1/0 (up): ip 192.168.10.1 dlci 202(0xCA,0x30A0), static,
 broadcast,
 CISCO, status defined, active
cnc2#s

cnc3#sh frame-relay map
Serial1/0 (up): ip 192.168.10.1 dlci 203(0xCB,0x30B0), static,
 broadcast,
 CISCO, status defined, active
cnc3#
------------------------------------------------
3. Konfigurasi NMBA OSPF (PtM)
------------------------------------------------
cnc1#
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 192.168.10.0 0.0.0.255 area 0
 network 192.168.20.0 0.0.0.255 area 0
!
------------------------------------------------
cnc1(config)#int s1/0
cnc1(config-if)#ip ospf network point-to-multipoint
------------------------------------------------
cnc2#
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 network 192.168.10.0 0.0.0.255 area 0
 network 192.168.30.0 0.0.0.255 area 0
!
------------------------------------------------
cnc2(config)#int s1/0
cnc2(config-if)#ip ospf network point-to-multipoint
------------------------------------------------
cnc3#
!
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 network 192.168.10.0 0.0.0.255 area 0
 network 192.168.40.0 0.0.0.255 area 0
!
------------------------------------------------
cnc3(config)#int s1/0
cnc3(config-if)#ip ospf network point-to-multipoint
------------------------------------------------
------------------------------------------------
4.how to check 2 (sh ip ospf interface)
------------------------------------------------
cnc1#sh ip ospf interface
Loopback0 is up, line protocol is up
 Internet Address 192.168.20.1/24, Area 0
 Process ID 1, Router ID 1.1.1.1, Network Type LOOPBACK, Cost: 1
 Loopback interface is treated as a stub Host
Serial1/0 is up, line protocol is up
 Internet Address 192.168.10.1/24, Area 0
 Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_MULTIPOINT, Cost: 64
 Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
 Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
 oob-resync timeout 120
 Hello due in 00:00:14
 Supports Link-local Signaling (LLS)
 Index 1/1, flood queue length 0
 Next 0x0(0)/0x0(0)
 Last flood scan length is 1, maximum is 2
 Last flood scan time is 4 msec, maximum is 8 msec
 Neighbor Count is 2, Adjacent neighbor count is 2
 Adjacent with neighbor 2.2.2.2
 Adjacent with neighbor 3.3.3.3
 Suppress hello for 0 neighbor(s)
cnc1#

cnc2#sh ip ospf interface
Loopback0 is up, line protocol is up
 Internet Address 192.168.30.1/24, Area 0
 Process ID 1, Router ID 2.2.2.2, Network Type LOOPBACK, Cost: 1
 Loopback interface is treated as a stub Host
Serial1/0 is up, line protocol is up
 Internet Address 192.168.10.2/24, Area 0
 Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_MULTIPOINT, Cost: 64
 Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
 Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
 oob-resync timeout 120
 Hello due in 00:00:27
 Supports Link-local Signaling (LLS)
 Index 1/1, flood queue length 0
 Next 0x0(0)/0x0(0)
 Last flood scan length is 1, maximum is 1
 Last flood scan time is 0 msec, maximum is 4 msec
 Neighbor Count is 1, Adjacent neighbor count is 1
 Adjacent with neighbor 1.1.1.1
 Suppress hello for 0 neighbor(s)
cnc2#

cnc3#sh ip ospf interface
Loopback3 is up, line protocol is up
 Internet Address 192.168.40.1/24, Area 0
 Process ID 1, Router ID 3.3.3.3, Network Type LOOPBACK, Cost: 1
 Loopback interface is treated as a stub Host
Serial1/0 is up, line protocol is up
 Internet Address 192.168.10.3/24, Area 0
 Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_MULTIPOINT, Cost: 64
 Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
 Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
 oob-resync timeout 120
 Hello due in 00:00:26
 Supports Link-local Signaling (LLS)
 Index 1/1, flood queue length 0
 Next 0x0(0)/0x0(0)
 Last flood scan length is 1, maximum is 1
 Last flood scan time is 0 msec, maximum is 4 msec
 Neighbor Count is 1, Adjacent neighbor count is 1
 Adjacent with neighbor 1.1.1.1
 Suppress hello for 0 neighbor(s)
cnc3#
------------------------------------------------
5.how to check 3 (sh ip ospf neighbor),no DR/BDR
elected.
------------------------------------------------
cnc1#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           0   FULL/  -        00:01:47    192.168.10.2    Serial1/0
3.3.3.3           0   FULL/  -        00:01:57    192.168.10.3    Serial1/0
cnc1#

cnc2#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           0   FULL/  -        00:01:07    192.168.10.1    Serial1/0
cnc2#

cnc3#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           0   FULL/  -        00:01:21    192.168.10.1    Serial1/0
cnc3#
------------------------------------------------
6.how to check 4 (sh ip route)
------------------------------------------------
cnc1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

 192.168.30.0/32 is subnetted, 1 subnets
O       192.168.30.1 [110/65] via 192.168.10.2, 00:03:39, Serial1/0
 192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks
O       192.168.10.2/32 [110/64] via 192.168.10.2, 00:03:39, Serial1/0
O       192.168.10.3/32 [110/64] via 192.168.10.3, 00:03:39, Serial1/0
C       192.168.10.0/24 is directly connected, Serial1/0
 192.168.40.0/32 is subnetted, 1 subnets
O       192.168.40.1 [110/65] via 192.168.10.3, 00:03:39, Serial1/0
C    192.168.20.0/24 is directly connected, Loopback0
cnc1#

cnc2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.30.0/24 is directly connected, Loopback0
 192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks
O       192.168.10.3/32 [110/128] via 192.168.10.1, 00:07:27, Serial1/0
C       192.168.10.0/24 is directly connected, Serial1/0
O       192.168.10.1/32 [110/64] via 192.168.10.1, 00:07:27, Serial1/0
 192.168.40.0/32 is subnetted, 1 subnets
O       192.168.40.1 [110/129] via 192.168.10.1, 00:07:27, Serial1/0
 192.168.20.0/32 is subnetted, 1 subnets
O       192.168.20.1 [110/65] via 192.168.10.1, 00:07:27, Serial1/0
cnc2#

cnc3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

 192.168.30.0/32 is subnetted, 1 subnets
O       192.168.30.1 [110/129] via 192.168.10.1, 00:07:15, Serial1/0
 192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks
O       192.168.10.2/32 [110/128] via 192.168.10.1, 00:07:15, Serial1/0
C       192.168.10.0/24 is directly connected, Serial1/0
O       192.168.10.1/32 [110/64] via 192.168.10.1, 00:07:15, Serial1/0
C    192.168.40.0/24 is directly connected, Loopback3
 192.168.20.0/32 is subnetted, 1 subnets
O       192.168.20.1 [110/65] via 192.168.10.1, 00:07:15, Serial1/0
cnc3#
------------------------------------------------
8.how to check 5 (ping)
------------------------------------------------
cnc2#pi
Protocol [ip]:
Target IP address: 192.168.40.1
Repeat count [5]: 100
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 192.168.40.1, timeout is 2 seconds:
.!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.!!!!!!!!!!!!!!.!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 97 percent (97/100), round-trip min/avg/max = 144/456/1736 ms
cnc2#
------------------------------------------------
"sekian dulu, semoga bermanfaat, CMIIW and salam
sedogedoi"

ref:
[1]. Cisco IOS IP Routing Protocols
Configuration Guide, http://www.cisco.com, (juni 2010)
One Comment leave one →
  1. 14 July 2010 3:40 AM

    makasih infonya langsung ke TKP

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: