Skip to content

Belajar Mengkonfigurasi Manual tunnel IPv6

12 April 2010
Penggantian infrastruktur secara langsung pada seluruh jaringan IPv4 menuju ke IPv6 tidak
dapat dilakukan serta merta karena beberapa hal,sehingga dibutuhkan mekanisme transisi.
Mekanisme yang sering digunakan adalah model tunneling. Pada implementasinya ada banyak meka
nisme transisi tunneling yang digunakan, mekanisme tadi seperti tabel dibawah ini :

Pada kesempatan ini, kita akan belajar mengkonfigurasi manual tunnel IPv6
Topology yang digunakan adalah sebagai berikut :
Peralatan yang digunakan:
--3 buah router
 -- 2 buah router harus support IPv6 (cnc1 dan cnc3)
 -- 1 buah router untuk simulasi IPv4 cloud (cnc2)
--1 buah hub
--3 buah komputer
 -- 2 buah komputer support IPv6 (com1 dan com 2)
 -- 1 buah komputer dengan wireshark,utk mengcapture
 data (komputer)
--kabel utp seperlunya
nb:cloud IPv4 sebelumnya telah disetting terlebih dahulu
menggunakan routing protocol ospfv2 dengan proses id 1
Langkah-langkahnya adalah sebagai berikut:

-Membuat Tunnel di router cnc1 dan cnc3
-------------------------------------------
cnc1#sh run int tun 1
Building configuration...

Current configuration : 172 bytes
!
interface Tunnel1
 no ip address
 ipv6 address FEC0::5:1/112
 tunnel source FastEthernet0/0
 tunnel destination 192.168.20.2
 tunnel mode ipv6ip
end

cnc1#

cnc3#sh run int tun 1
Building configuration...

Current configuration : 173 bytes
!
interface Tunnel1
 no ip address
 ipv6 address FEC0::5:2/112
 tunnel source FastEthernet0/1
 tunnel destination 192.168.10.65
 tunnel mode ipv6ip
end

cnc3#
-------------------------------------------
How to check 1 (sh ipv6 int brief)
-------------------------------------------
cnc1#sh ipv6 int brief
FastEthernet0/0            [up/up]
FastEthernet0/1            [up/up]
 FE80::224:97FF:FE4C:8B21
 FEC0::1:1
Loopback0                  [up/up]
 FE80::224:97FF:FE4C:8B20
 FEC0::2:1
Tunnel1                    [up/up]
 FE80::C0A8:A41
 FEC0::5:1
cnc1#

cnc3#sh ipv6 int brief
FastEthernet0/0            [up/up]
 FE80::224:97FF:FE4C:8C28
 FEC0::4:1
FastEthernet0/1            [up/up]
Loopback0                  [up/up]
 FE80::224:97FF:FE4C:8C28
 FEC0::3:1
Tunnel1                    [up/up]
 FE80::C0A8:1402
 FEC0::5:2
cnc3#
-------------------------------------------
How to check 2 (sh int tun [])
-------------------------------------------
cnc1#sh int tun 1
Tunnel1 is up, line protocol is up
 Hardware is Tunnel
 MTU 1514 bytes, BW 9 Kbit/sec, DLY 500000 usec,
 reliability 255/255, txload 28/255, rxload 56/255
 Encapsulation TUNNEL, loopback not set
 Keepalive not set
 Tunnel source 192.168.10.65 (FastEthernet0/0), destination 192.168.20.2
 Tunnel protocol/transport IPv6/IP
 Tunnel TTL 255
 Fast tunneling enabled
 Tunnel transmit bandwidth 8000 (kbps)
 Tunnel receive bandwidth 8000 (kbps)
 Last input 00:00:00, output 00:00:00, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/0 (size/max)
 5 minute input rate 2000 bits/sec, 2 packets/sec
 5 minute output rate 1000 bits/sec, 2 packets/sec
 597 packets input, 67377 bytes, 0 no buffer
 Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
 662 packets output, 68347 bytes, 0 underruns
 0 output errors, 0 collisions, 0 interface resets
 0 unknown protocol drops
 0 output buffer failures, 0 output buffers swapped out
cnc1#

cnc3#sh int tun 1
Tunnel1 is up, line protocol is up
 Hardware is Tunnel
 MTU 1514 bytes, BW 9 Kbit/sec, DLY 500000 usec,
 reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation TUNNEL, loopback not set
 Keepalive not set
 Tunnel source 192.168.20.2 (FastEthernet0/1), destination 192.168.10.65
 Tunnel protocol/transport IPv6/IP
 Tunnel TTL 255
 Fast tunneling enabled
 Tunnel transmit bandwidth 8000 (kbps)
 Tunnel receive bandwidth 8000 (kbps)
 Last input 00:00:03, output 00:00:08, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/0 (size/max)
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
 679 packets input, 79632 bytes, 0 no buffer
 Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
 636 packets output, 62816 bytes, 0 underruns
 0 output errors, 0 collisions, 0 interface resets
 0 unknown protocol drops
 0 output buffer failures, 0 output buffers swapped out
cnc3#
--------------------------------------------
How to check 3 (ping)
--------------------------------------------
cnc1#ping fec0::5:2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::5:2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/2/4 ms
cnc1#

cnc3#ping fec0::5:1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::5:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/1/4 ms
cnc3#
-------------------------------------------
-Menambahkan routing protocol di tunnel
,pada percobaan ini menggunakan ospfv3
-------------------------------------------

cnc1(config)# ipv6 unicast-routing
cnc1(config)# interface loopback0
cnc1(config-if)# ipv6 ospf 2 area 0
cnc1(config-if)# interface tunnel0
cnc1(config-if)# ipv6 ospf 2 area 0
cnc1(config-if)# interface f0/1
cnc1(config-if)# ipv6 ospf 2 area 0

cnc3(config)# ipv6 unicast-routing
cnc3(config)# interface loopback0
cnc3(config-if)# ipv6 ospf 2 area 0
cnc3(config-if)# interface tunnel0
cnc3(config-if)# ipv6 ospf 2 area 0
cnc3(config-if)# interface f0/0
cnc3(config-if)# ipv6 ospf 2 area 0
-------------------------------------------
How to check 4 (sh ipv6 ospf neighbor)
--------------------------------------------
cnc1#sh ipv6 ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
10.10.10.3        1   FULL/  -        00:00:32    9               Tunnel1
cnc1#

cnc3#sh ipv6 ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
10.10.10.1        1   FULL/  -        00:00:34    10              Tunnel1
cnc3#
--------------------------------------------
How to check 5 (sh ipv6 route)
--------------------------------------------
cnc1#sh ipv6 route
IPv6 Routing Table - 10 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
 U - Per-user Static route
 I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
 O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
 ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
L   FE80::/10 [0/0]
 via ::, Null0
C   FEC0::1:0/112 [0/0]
 via ::, FastEthernet0/1
L   FEC0::1:1/128 [0/0]
 via ::, FastEthernet0/1
C   FEC0::2:0/112 [0/0]
 via ::, Loopback0
L   FEC0::2:1/128 [0/0]
 via ::, Loopback0
O   FEC0::3:1/128 [110/11111]
 via FE80::C0A8:1402, Tunnel1
O   FEC0::4:0/112 [110/11112]
 via FE80::C0A8:1402, Tunnel1
C   FEC0::5:0/112 [0/0]
 via ::, Tunnel1
L   FEC0::5:1/128 [0/0]
 via ::, Tunnel1
L   FF00::/8 [0/0]
 via ::, Null0
cnc1#

cnc3#sh ipv6 route
IPv6 Routing Table - 10 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
 U - Per-user Static route
 I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
 O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
 ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
L   FE80::/10 [0/0]
 via ::, Null0
O   FEC0::1:0/112 [110/11112]
 via FE80::C0A8:A41, Tunnel1
O   FEC0::2:1/128 [110/11111]
 via FE80::C0A8:A41, Tunnel1
C   FEC0::3:0/112 [0/0]
 via ::, Loopback0
L   FEC0::3:1/128 [0/0]
 via ::, Loopback0
C   FEC0::4:0/112 [0/0]
 via ::, FastEthernet0/0
L   FEC0::4:1/128 [0/0]
 via ::, FastEthernet0/0
C   FEC0::5:0/112 [0/0]
 via ::, Tunnel1
L   FEC0::5:2/128 [0/0]
 via ::, Tunnel1
L   FF00::/8 [0/0]
 via ::, Null0
cnc3#
-------------------------------------------
How to check 6 (ping6 and treceroute6)
-------------------------------------------
root@toiletumum:/home/harry# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:1b:24:6d:49:2b  
 inet6 addr: fe80::21b:24ff:fe6d:492b/64 Scope:Link
 inet6 addr: fec0::4:2/112 Scope:Site
 UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
 RX packets:483 errors:0 dropped:0 overruns:0 frame:0
 TX packets:615 errors:0 dropped:0 overruns:0 carrier:0
 collisions:0 txqueuelen:1000
 RX bytes:46201 (46.2 KB)  TX bytes:51861 (51.8 KB)
 Interrupt:27 Base address:0x8000 

root@toiletumum:/home/harry#

root@toiletumum:/home/harry# ping6 fec0::1:2
PING fec0::1:2(fec0::1:2) 56 data bytes
64 bytes from fec0::1:2: icmp_seq=1 ttl=62 time=0.833 ms
64 bytes from fec0::1:2: icmp_seq=2 ttl=62 time=0.770 ms
64 bytes from fec0::1:2: icmp_seq=3 ttl=62 time=0.810 ms
64 bytes from fec0::1:2: icmp_seq=4 ttl=62 time=0.820 ms
64 bytes from fec0::1:2: icmp_seq=5 ttl=62 time=0.832 ms
^C
--- fec0::1:2 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 3996ms
rtt min/avg/max/mdev = 0.770/0.813/0.833/0.023 ms

root@toiletumum:/home/harry# traceroute6 fec0::1:2
traceroute to fec0::1:2 (fec0::1:2) from fec0::4:2, 30 hops max, 16 byte packets
 1  fec0::4:1 (fec0::4:1)  0.651 ms  0.468 ms  0.455 ms
 2  fec0::5:1 (fec0::5:1)  1.327 ms  1.065 ms  1.032 ms
 3  fec0::1:2 (fec0::1:2)  0.573 ms  0.809 ms  0.442 ms
root@toiletumum:/home/harry# 

-------------------------------------------
wireshark ipv6ip

-------------------------------------------
konfigurasi lengkapnya
-------------------------------------------
cnc1#sh run
Building configuration...

Current configuration : 1285 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname cnc1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$XnAA$IaSpaeMSOyHz8uloQd1J..
!
no aaa new-model
!
!
ip cef
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
ipv6 cef
!
voice-card 0
 no dspfarm
!
interface Loopback0
 ip address 10.10.10.1 255.255.255.255
 ipv6 address FEC0::2:1/112
 ipv6 ospf 2 area 0
!
interface Tunnel1
 no ip address
 ipv6 address FEC0::5:1/112
 ipv6 ospf 2 area 0
 tunnel source FastEthernet0/0
 tunnel destination 192.168.20.2
 tunnel mode ipv6ip
!
interface FastEthernet0/0
 ip address 192.168.10.65 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address FEC0::1:1/112
 ipv6 ospf 2 area 0
!
router ospf 1
 log-adjacency-changes
 network 10.10.10.1 0.0.0.0 area 0
 network 192.168.10.64 0.0.0.3 area 0
!
ip forward-protocol nd
!       
ip http server
no ip http secure-server
!
ipv6 router ospf 2
 log-adjacency-changes
!
control-plane
!
line con 0
line aux 0
line vty 0 4
 password 7 xxxx
 login
!
scheduler allocate 20000 1000
!
end

cnc1# 

cnc3#sh run
Building configuration...

Current configuration : 1304 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname cnc3
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$07L9$07XS6yvACJM3wgpyRkjOZ/
!
no aaa new-model
!
!
ip cef
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
ipv6 cef
!
voice-card 0
 no dspfarm
!
interface Loopback0
 ip address 10.10.10.3 255.255.255.255
 ipv6 address FEC0::3:1/112
 ipv6 ospf 2 area 0
!
interface Tunnel1
 no ip address
 ipv6 address FEC0::5:2/112
 ipv6 ospf 2 area 0
 tunnel source FastEthernet0/1
 tunnel destination 192.168.10.65
 tunnel mode ipv6ip
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address FEC0::4:1/112
 ipv6 ospf 2 area 0
!
interface FastEthernet0/1
 ip address 192.168.20.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 10.10.10.3 0.0.0.0 area 0
 network 192.168.20.0 0.0.0.255 area 0
!
ip forward-protocol nd
!         
ip http server
no ip http secure-server
!
ipv6 router ospf 2
 log-adjacency-changes
!
control-plane
!
line con 0
line aux 0
line vty 0 4
 password 7 xxxx
 login
!
scheduler allocate 20000 1000
!
end

cnc3#
-------------------------------------------
"Sekian dulu dan semoga bermanfaat"

ref:
[1]Cisco IOS IPv6 Configuration Guide,
URL:http://www.cisco.com, (April 2010)
No comments yet

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: