Skip to content

Belajar Simulasi CISCO MPLS-L3VPN (PE-CE with RIPv2)

21 February 2010
Belajar Simulasi CISCO MPLS-L3VPN (PE-CE with RIPv2)
Topology yang saya gunakan adalah seperti gambar dibawah ini:


Konfigurasi IP addressnya adalah sebagai berikut:

Dan Langkah-langkahnya adalah sebagai berikut:

Pertama:
configure semua interface (PE1-Core-PE2)

---------------core----------------------
!
interface Loopback0
 ip address 192.168.100.1 255.255.255.255
!
interface GigabitEthernet1/0
 ip address 192.168.10.10 255.255.255.252
!
interface GigabitEthernet2/0
 ip address 192.168.10.13 255.255.255.252
-----------------------------------------

---------------PE1-----------------------
interface Loopback0
 ip address 192.168.100.2 255.255.255.255
!
interface GigabitEthernet1/0
 ip address 192.168.10.9 255.255.255.252
-----------------------------------------

---------------PE2-----------------------
interface Loopback0
 ip address 192.168.100.3 255.255.255.255
!
interface GigabitEthernet1/0
 ip address 192.168.10.14 255.255.255.252
-----------------------------------------

Kedua:Aktifkan Dynamic Routing 

---------------core----------------------
router ospf 1
 network 192.168.10.0 0.0.0.255 area 0
 network 192.168.100.1 0.0.0.0 area 0
-----------------------------------------

---------------PE1-----------------------
router ospf 1
 network 192.168.10.0 0.0.0.255 area 0
 network 192.168.100.2 0.0.0.0 area 0
-----------------------------------------

---------------PE2-----------------------
router ospf 1
 network 192.168.10.0 0.0.0.255 area 0
 network 192.168.100.3 0.0.0.0 area 0
-----------------------------------------
untuk pengecekan : ketikan show ip route

PE1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

 192.168.10.0/30 is subnetted, 2 subnets
C       192.168.10.8 is directly connected, GigabitEthernet1/0
O       192.168.10.12 [110/2] via 192.168.10.10, 00:23:16, GigabitEthernet1/0
 192.168.100.0/32 is subnetted, 3 subnets
O       192.168.100.1 [110/2] via 192.168.10.10, 00:23:16, GigabitEthernet1/0
C       192.168.100.2 is directly connected, Loopback0
O       192.168.100.3 [110/3] via 192.168.10.10, 00:23:16, GigabitEthernet1/0
PE1#

PE2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

 192.168.10.0/30 is subnetted, 2 subnets
O       192.168.10.8 [110/2] via 192.168.10.13, 00:18:13, GigabitEthernet1/0
C       192.168.10.12 is directly connected, GigabitEthernet1/0
 192.168.100.0/32 is subnetted, 3 subnets
O       192.168.100.1 [110/2] via 192.168.10.13, 00:18:23, GigabitEthernet1/0
O       192.168.100.2 [110/3] via 192.168.10.13, 00:18:13, GigabitEthernet1/0
C       192.168.100.3 is directly connected, Loopback0
PE2#

Ketiga:Aktifkan BGP

---------------PE1-----------------------
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.168.100.3 remote-as 100
 neighbor 192.168.100.3 update-source Loopback0
 no auto-summary
-----------------------------------------

---------------PE2-----------------------
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.168.100.2 remote-as 100
 neighbor 192.168.100.2 update-source Loopback0
 no auto-summary
-----------------------------------------
untuk pengecekan : ketikan show ip bgp sum

PE1# sh ip bgp summary
BGP router identifier 192.168.100.2, local AS number 100
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
192.168.100.3   4   100      28      36        1    0    0 00:30:32        0
PE1#

PE2#sh ip bgp summary
BGP router identifier 192.168.100.3, local AS number 100
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
192.168.100.2   4   100      35      28        1    0    0 00:23:27        0
PE2#

Keempat:Aktifkan MPLS
---------------core----------------------
ip cef
!
mpls label protocol ldp
!
interface GigabitEthernet1/0
 ip address 192.168.10.10 255.255.255.252
 mpls ip
!
interface GigabitEthernet2/0
 ip address 192.168.10.13 255.255.255.252
 mpls ip
-----------------------------------------

---------------PE1-----------------------
ip cef
!
mpls label protocol ldp
!
mpls ldp router-id Loopback0 force
!
interface GigabitEthernet1/0
 ip address 192.168.10.9 255.255.255.252
 mpls ip
-----------------------------------------

---------------PE2-----------------------
ip cef
!
mpls label protocol ldp
!
mpls ldp router-id Loopback0 force
!
interface GigabitEthernet1/0
 ip address 192.168.10.14 255.255.255.252
 mpls ip
-----------------------------------------
untuk pengecekan : ketikan show mpls ldp neighbor

core#show mpls ldp neighbor
 Peer LDP Ident: 192.168.100.3:0; Local LDP Ident 192.168.100.1:0
 TCP connection: 192.168.100.3.26601 - 192.168.100.1.646
 State: Oper; Msgs sent/rcvd: 45/36; Downstream
 Up time: 00:32:49
 LDP discovery sources:
 GigabitEthernet2/0, Src IP addr: 192.168.10.14
 Addresses bound to peer LDP Ident:
 192.168.10.14   192.168.100.3
 Peer LDP Ident: 192.168.100.2:0; Local LDP Ident 192.168.100.1:0
 TCP connection: 192.168.100.2.31760 - 192.168.100.1.646
 State: Oper; Msgs sent/rcvd: 45/44; Downstream
 Up time: 00:32:32
 LDP discovery sources:
 GigabitEthernet1/0, Src IP addr: 192.168.10.9
 Addresses bound to peer LDP Ident:
 192.168.10.9    192.168.100.2
core#

PE1#sh mpls ldp neighbor
 Peer LDP Ident: 192.168.100.1:0; Local LDP Ident 192.168.100.2:0
 TCP connection: 192.168.100.1.646 - 192.168.100.2.31760
 State: Oper; Msgs sent/rcvd: 43/44; Downstream
 Up time: 00:31:35
 LDP discovery sources:
 GigabitEthernet1/0, Src IP addr: 192.168.10.10
 Addresses bound to peer LDP Ident:
 192.168.10.10   192.168.100.1   192.168.10.13
PE1#

PE2#show mpls ldp neighbor
 Peer LDP Ident: 192.168.100.1:0; Local LDP Ident 192.168.100.3:0
 TCP connection: 192.168.100.1.646 - 192.168.100.3.26601
 State: Oper; Msgs sent/rcvd: 37/45; Downstream
 Up time: 00:25:54
 LDP discovery sources:
 GigabitEthernet1/0, Src IP addr: 192.168.10.13
 Addresses bound to peer LDP Ident:
 192.168.10.10   192.168.100.1   192.168.10.13
PE2#

Kelima:Buat Router Virtual
---------------PE1-----------------------
ip vrf cnc2
 rd 100:2
 route-target export 100:2
 route-target import 100:2
!
interface GigabitEthernet3/0
 ip vrf forwarding cnc2
 ip address 192.168.10.6 255.255.255.252
 negotiation auto

---------------PE2-----------------------
ip vrf cnc2
 rd 100:2
 route-target export 100:2
 route-target import 100:2
!
interface GigabitEthernet3/0
 ip vrf forwarding cnc2
 ip address 192.168.10.21 255.255.255.252
 negotiation auto

-----------------------------------------
untuk pengecekan : ketikan show ip vrf (name)

Keenam: Menambahkan Routing DiRouter Virtual

---------------PE1-----------------------

router rip
 version 2
 no auto-summary
 !
 address-family ipv4 vrf cnc2
 redistribute bgp 100 metric transparent
 network 10.0.0.0
 network 192.168.10.0
 network 192.168.100.0
 no auto-summary
 exit-address-family

-----------------------------------------

---------------PE2-----------------------
router rip
 version 2
 no auto-summary
 !
 address-family ipv4 vrf cnc2
 redistribute bgp 100 metric transparent
 network 10.0.0.0
 network 192.168.10.0
 network 192.168.100.0
 no auto-summary
 exit-address-family

-----------------------------------------
untuk pengecekan : ketikan show ip vrf (name)

PE1#sh ip route vrf cnc2

Routing Table: cnc2
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

 192.168.10.0/30 is subnetted, 2 subnets
C       192.168.10.4 is directly connected, GigabitEthernet3/0
B       192.168.10.20 [200/0] via 192.168.100.3, 00:09:19
 10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R       10.14.200.0/24 [120/1] via 192.168.10.5, 00:00:00, GigabitEthernet3/0
B       10.14.200.2/32 [200/1] via 192.168.100.3, 00:09:02
PE1#

PE2#sh ip route vrf cnc2

Routing Table: cnc2
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

 192.168.10.0/30 is subnetted, 2 subnets
B       192.168.10.4 [200/0] via 192.168.100.2, 00:09:01
C       192.168.10.20 is directly connected, GigabitEthernet3/0
 10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B       10.14.200.0/24 [200/1] via 192.168.100.2, 00:08:46
R       10.14.200.2/32 [120/1] via 192.168.10.22, 00:00:28, GigabitEthernet3/0
PE2#

Ketujuh: Aktifkan MP-BGP

---------------PE1-----------------------
router bgp 100
 bgp router-id 192.168.100.2
 bgp log-neighbor-changes
 neighbor 192.168.100.3 remote-as 100
 neighbor 192.168.100.3 update-source Loopback0
 !
 address-family ipv4
 neighbor 192.168.100.3 activate
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 192.168.100.3 activate
 neighbor 192.168.100.3 send-community both
 exit-address-family
 !
 address-family ipv4 vrf cnc2
 redistribute rip
 no synchronization
 exit-address-family
!
-----------------------------------------

---------------PE2-----------------------
router bgp 100
 bgp router-id 192.168.100.3
 bgp log-neighbor-changes
 neighbor 192.168.100.2 remote-as 100
 neighbor 192.168.100.2 update-source Loopback0
 !
 address-family ipv4
 neighbor 192.168.100.2 activate
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 192.168.100.2 activate
 neighbor 192.168.100.2 send-community both
 exit-address-family
 !
address-family ipv4 vrf cnc2
 redistribute rip
 no synchronization
 exit-address-family

-----------------------------------------

Kedelapan: Mengaktifkan CE dan Pengujian End-to-end

---------------cnc2_x--------------------

router rip
 version 2
 network 10.0.0.0
 network 192.168.10.0
 no auto-summary

-----------------------------------------

--------------cnc2_y---------------------

router rip
 version 2
 network 10.0.0.0
 network 192.168.10.0
 no auto-summary

-----------------------------------------

untuk pengecekan : pergunakan perintah sh ip route, ping,traceroute dan telnet

cnc2_x#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

 192.168.10.0/30 is subnetted, 2 subnets
C       192.168.10.4 is directly connected, GigabitEthernet1/0
R       192.168.10.20 [120/1] via 192.168.10.6, 00:00:06, GigabitEthernet1/0
 10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.14.200.0/24 is directly connected, Loopback0
R       10.14.200.2/32 [120/2] via 192.168.10.6, 00:00:06, GigabitEthernet1/0
cnc2_x#

cnc2_y#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

 192.168.10.0/30 is subnetted, 2 subnets
R       192.168.10.4 [120/1] via 192.168.10.21, 00:00:16, GigabitEthernet1/0
C       192.168.10.20 is directly connected, GigabitEthernet1/0
 10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R       10.14.200.0/24 [120/2] via 192.168.10.21, 00:00:16, GigabitEthernet1/0
C       10.14.200.2/32 is directly connected, Loopback0
cnc2_y#

cnc2_x#ping 10.14.200.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.14.200.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 332/386/476 ms
cnc2_x#

cnc2_y#ping 10.14.200.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.14.200.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 332/389/428 ms
cnc2_y#

cnc2_x#traceroute 10.14.200.2

Type escape sequence to abort.
Tracing the route to 10.14.200.2

 1 192.168.10.6 144 msec 208 msec 68 msec
 2 192.168.10.10 [MPLS: Labels 16/22 Exp 0] 308 msec 264 msec 404 msec
 3 192.168.10.21 [MPLS: Label 22 Exp 0] 260 msec 220 msec 764 msec
 4 192.168.10.22 404 msec 344 msec *
cnc2_x#

cnc2_y#traceroute 10.14.200.1

Type escape sequence to abort.
Tracing the route to 10.14.200.1

 1 192.168.10.21 100 msec 100 msec 160 msec
 2 192.168.10.13 [MPLS: Labels 17/22 Exp 0] 732 msec 412 msec 260 msec
 3 192.168.10.6 [MPLS: Label 22 Exp 0] 260 msec 268 msec 188 msec
 4 192.168.10.5 308 msec 244 msec *
cnc2_y#

cnc2_x#telnet 10.14.200.2
Trying 10.14.200.2 ... Open

User Access Verification

Password:
cnc2_y>

cnc2_y#telnet 10.14.200.1
Trying 10.14.200.1 ... Open

User Access Verification

Password:
cnc2_x>

"------------Sekian dulu, semoga bermanfaat------------------"

Ref:
[1]Rasyid,Rafdian.EXPERIMENT Cisco MPLS-L3VPN Dengan GNS3,
URL: http://www.ilmukomputer.com,(Februari 2010)   
[2]PE-CE Routing (RIPv2), URL:http://www.ccie18473.net,(Februari 2010)
[3]Cisco IOS Multiprotocol Label Switching Configuration Guide,
URL:http://www.cisco.com, (Februari 2010)
3 Comments leave one →
  1. budi permalink
    22 June 2010 9:07 AM

    bang, tu simulasi pake pacjet tracer bisa ga? klo mau yg bisa bgp, make software apa ya? thanks

    • 22 June 2010 9:21 AM

      saya simulasi pake GNS3, http://www.gns3.net , kalau dipaket tracer belum pernah coba.
      kalau mau full comand bisa mengemulate ios cisco di gns3 ^_^

  2. madley permalink
    8 May 2011 11:17 AM

    mas kalo mau bikin simulasi tentang RIPv2 pake gns3 gmana iaah..
    terus minta penjelasannya mas klo bisa ama contohnya..
    makasih..

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: