Skip to content

Redistribute ISIS into OSPF

16 February 2010
Topology :

Configuration:
------------------------------------------------------
Router cnc1:
cnc1#show run

version 12.4
!
hostname cnc1
!
ip cef
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.10.1 255.255.255.252
 ip ospf network point-to-point
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 192.168.10.0 0.0.0.3 area 0
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
!
!
end
cnc1#
-------------------------------------------------
cnc2#show running-config
!
version 12.4
!
hostname cnc2
!
ip cef
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.10.2 255.255.255.252
 ip ospf network point-to-point
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.10.5 255.255.255.252
 ip router isis
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 redistribute isis level-2 subnets
 network 2.2.2.2 0.0.0.0 area 0
 network 192.168.10.0 0.0.0.3 area 0
!
router isis
 net 49.0001.1111.1111.1111.00
 is-type level-2-only
 redistribute ospf 1
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
!
!
end
cnc2#
------------------------------------------------
cnc3#sh run

version 12.4n
!
hostname cnc3
!
ip cef
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.10.6 255.255.255.252
 ip router isis
 duplex auto
 speed auto
!
router isis
 net 49.0001.2222.2222.2222.00
 is-type level-2-only
 passive-interface Loopback0
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
!
!
end
cnc3#
---------------------------------------------
How to check :
cnc1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/2] via 192.168.10.2, 00:10:17, FastEthernet0/0
     3.0.0.0/32 is subnetted, 1 subnets
O E2    3.3.3.3 [110/20] via 192.168.10.2, 00:10:17, FastEthernet0/0
 192.168.10.0/30 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, FastEthernet0/0
cnc1#

cnc2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/2] via 192.168.10.1, 00:10:40, FastEthernet0/0
     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     3.0.0.0/32 is subnetted, 1 subnets
i L2    3.3.3.3 [115/10] via 192.168.10.6, FastEthernet1/0
 192.168.10.0/30 is subnetted, 2 subnets
C       192.168.10.0 is directly connected, FastEthernet0/0
C       192.168.10.4 is directly connected, FastEthernet1/0
cnc2#

cnc3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
i L2    1.1.1.1 [115/10] via 192.168.10.5, FastEthernet0/0
     2.0.0.0/32 is subnetted, 1 subnets
i L2    2.2.2.2 [115/10] via 192.168.10.5, FastEthernet0/0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0
 192.168.10.0/30 is subnetted, 2 subnets
i L2    192.168.10.0 [115/10] via 192.168.10.5, FastEthernet0/0
C       192.168.10.4 is directly connected, FastEthernet0/0
cnc3#

cnc1#ping 3.3.3.3 source lo0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 328/408/500 ms
cnc1#

cnc3#ping 1.1.1.1 source loopback 0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 3.3.3.3
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 336/620/1520 ms
cnc3#

cnc3#show isis database detail

IS-IS Level-2 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
cnc2.00-00            0x00000005   0xFC61        855               0/0/0
 Area Address: 49.0001
 NLPID:        0xCC
 Hostname: cnc2
 IP Address:   192.168.10.5
 Metric: 10         IS cnc3.01
 Metric: 0          IP-External 1.1.1.1 255.255.255.255
 Metric: 0          IP-External 2.2.2.2 255.255.255.255
 Metric: 0          IP-External 192.168.10.0 255.255.255.252
 Metric: 10         IP 192.168.10.4 255.255.255.252
cnc3.00-00          * 0x00000004   0xA1D0        707               0/0/0
 Area Address: 49.0001
 NLPID:        0xCC
 Hostname: cnc3
 IP Address:   3.3.3.3
 Metric: 10         IS cnc3.01
 Metric: 0          IP 3.3.3.3 255.255.255.255
 Metric: 10         IP 192.168.10.4 255.255.255.252
cnc3.01-00          * 0x00000002   0xB32A        482               0/0/0
 Metric: 0          IS cnc3.00
 Metric: 0          IS cnc2.00
cnc3#

cnc1#show ip ospf database

 OSPF Router with ID (1.1.1.1) (Process ID 1)

 Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         1932        0x80000003 0x005FB7 3
2.2.2.2         2.2.2.2         1337        0x80000004 0x008585 3

 Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
3.3.3.3         2.2.2.2         1337        0x80000001 0x00216B 0
cnc1#

inspiration from : debugall
No comments yet

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: