Skip to content

Belajar mensetting rate-limit

3 May 2010
Suatu pagi si bos memerintahkan untuk membatasi suatu network  
dengan spesifikasi sebagai berikut, uplink dibatasi sebesar 1024000 bps
(1 Mega)dan downlink sebesar 2048000 bps (2 Mega). Gue juga bingung bagaimana
cara setting di device nya (red:cisco), lalu gue buka catatan2 dari kakak
kelas gue mengenai rate limit. Sebanernya gue masih bingung dengan angka2
yang gue setting sendiri, ini sebagai bahan pelajaran gue...@_@, jujur aja
gue masih bingung dengan konsepnya. 

konfigurasi dibawah adalah hasil dari percobaan dilab, cekidot :
!konfigurasi umumnya adalah sebagai berikut 

rate-limit {input | output} [dscp dscp-value] [access-group [rate-limit]
acl-index] bps  burst-normal burst-max conform-action conform-action
exceed-action exceed-action  

!untuk uplink
----------------------------------------------
cnc1(config-if)#rate-limit ?
 input   Rate limit on input
 output  Rate limit on output
----------------------------------------------
cnc1(config-if)#rate-limit input ?
 <8000-2000000000>  Bits per second
 access-group       Match access list
 dscp               Match dscp value
 qos-group          Match qos-group ID
----------------------------------------------
cnc1(config-if)#rate-limit input 1024000 ?
 <1000-512000000>  Normal burst bytes 

! dari mana nilai Normal burst ini, ini berasal dari formula berikut:
! normal burst = configured rate * (1 byte)/(8 bits) * 1.5 seconds
! normal burst = 1024000 * (1 byte)/(8 bits ) * 1,5 = 192000 bytes
----------------------------------------------
cnc1(config-if)#rate-limit input 1024000 192000 ?
 <2000-1024000000>  Maximum burst bytes
! dari mana nilai Maximum burst ini, ini berasal dari formula berikut:
! extended burst = 2 * normal burst
! extended burst = 2 * 192000 = 384000 bytes
----------------------------------------------
cnc1(config-if)#rate-limit input 1024000 192000 384000 ?
 conform-action  action when rate not exceeded
----------------------------------------------
cnc1(config-if)#rate-limit input 1024000 192000 384000 conform-action ?
 continue                          scan other rate limits
 drop                              drop packet
 set-dscp-continue                 set dscp, scan other rate limits
 set-dscp-transmit                 set dscp and send it
 set-mpls-exp-imposition-continue  set exp during imposition, scan other rate limits
 set-mpls-exp-imposition-transmit  set exp during imposition and send it
 set-prec-continue                 rewrite packet precedence, scan other rate limits
 set-prec-transmit                 rewrite packet precedence and send it
 set-qos-continue                  set qos-group, scan other rate limits
 set-qos-transmit                  set qos-group and send it
 transmit                          transmit packet
----------------------------------------------
cnc1(config-if)#rate-limit input 1024000 192000 384000 conform-action transmit ?
 exceed-action  action when rate exceeded
----------------------------------------------
cnc1(config-if)#rate-limit input 1024000 192000 384000 conform-action transmit exceed-action ?
 continue                          scan other rate limits
 drop                              drop packet
 set-dscp-continue                 set dscp, scan other rate limits
 set-dscp-transmit                 set dscp and send it
 set-mpls-exp-imposition-continue  set exp during imposition and send it
 set-mpls-exp-imposition-transmit  set exp during imposition and send it
 set-prec-continue                 rewrite packet precedence, scan other rate limits
 set-prec-transmit                 rewrite packet precedence and send it
 set-qos-continue                  set qos-group, scan other rate limits
 set-qos-transmit                  set qos-group and send it
 transmit                          transmit packet
----------------------------------------------
!untuk downlink
cnc1(config-if)#rate-limit output 2048000 384000 768000 conform-action transmit exceed-action drop
----------------------------------------------
!konfigurasi lengkap nya
interface FastEthernet0/1
 ip address 192.168.60.1 255.255.255.0
 rate-limit input 1024000 192000 384000 conform-action transmit exceed-action drop
 rate-limit output 2048000 384000 768000 conform-action transmit exceed-action drop
 duplex auto
 speed auto
----------------------------------------------
ini hasil dari capture-an menggunakan cacti : 





----------------------------------------------
nah kalau ini contoh dari konfigurasi kakak kelas gue:
!
interface FastEthernet0/0.101
 description LAN POP DPS1
 encapsulation dot1Q 101
 ip address 202.x.x.x 255.255.255.252
 rate-limit input 1024000 96000 192000 conform-action transmit exceed-action drop
 rate-limit output 896000 84000 168000 conform-action transmit exceed-action drop
 no cdp enable
!
interface FastEthernet0/0.102
 description LAN POP DPS2
 encapsulation dot1Q 102
 ip address 202.x.x.x 255.255.255.248
 ip access-group WORM in
 ip access-group WORM out
 rate-limit input 256000 48000 48000 conform-action transmit exceed-action drop
 rate-limit output 8000 1500 2000 conform-action transmit exceed-action drop
 no cdp enable
!
interface FastEthernet0/0.103
 description LAN POP DPS3
 encapsulation dot1Q 103
 ip address 202.x.x.x 255.255.255.248
 ip access-group WORM in
 ip access-group WORM out
 rate-limit input 32000 16000 128000 conform-action transmit exceed-action drop
 rate-limit output 96000 16000 128000 conform-action transmit exceed-action drop
 no cdp enable
----------------------------------------------
Wah gue harus belajar lagi mengenai hal ini T_T, gue masih bingung
normal sama extended burst ngefeknya dibagian mana, CMIIW and tks be 4.
ref: Cisco IOS Quality of Service Solutions Command Reference,
Release 12.2, URL: htto://www.cisco.com
About these ads
No comments yet

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

Join 25 other followers

%d bloggers like this: