Skip to content

Belajar Mengkonfigurasi IPv6 over GRE IPv6

15 April 2010
Belajar Mengkonfigurasi IPv6 over GRE IPv6
Topology yang digunakan adalah sebagai berikut:

Langkah-langkahnya adalah sebagai berikut:
-Membuat Tunnel di router cnc1 dan cnc3
-------------------------------------------
cnc1#sh run int tun 1
Building configuration... 

Current configuration : 184 bytes
!
interface Tunnel1
 no ip address
 ipv6 address FEC0::6:1/112
 ipv6 enable
 ipv6 ospf 1 area 0
 tunnel source FastEthernet0/0
 tunnel destination FEC0::4:2
 tunnel mode gre ipv6
end 

cnc1# 

cnc3#sh run int tun 1
Building configuration... 

Current configuration : 184 bytes
!
interface Tunnel1
 no ip address
 ipv6 address FEC0::6:2/112
 ipv6 enable
 ipv6 ospf 1 area 0
 tunnel source FastEthernet0/0
 tunnel destination FEC0::2:1
 tunnel mode gre ipv6
end 

cnc3#
-------------------------------------------
How to check 1 (sh ipv6 int brief)
-------------------------------------------
cnc1#sh ipv6 int brief
FastEthernet0/0            [up/up]
 FE80::C800:EFF:FE04:0
 FEC0::2:1
FastEthernet1/0            [administratively down/down]
 unassigned
FastEthernet1/1            [administratively down/down]
 unassigned
SSLVPN-VIF0                [up/up]
 unassigned
Loopback0                  [up/up]
 FE80::C800:EFF:FE04:0
 FEC0::1:1
Tunnel1                    [up/up]
 FE80::C800:EFF:FE04:0
 FEC0::6:1
cnc1# 

cnc3#sh ipv6 int brief
FastEthernet0/0            [up/up]
 FE80::C802:EFF:FE58:0
 FEC0::4:2
FastEthernet1/0            [administratively down/down]
 unassigned
FastEthernet1/1            [administratively down/down]
 unassigned
SSLVPN-VIF0                [up/up]
 unassigned
Loopback0                  [up/up]
 FE80::C802:EFF:FE58:0
 FEC0::5:1
Tunnel1                    [up/up]
 FE80::C802:EFF:FE58:0
 FEC0::6:2
cnc3#
-------------------------------------------
How to check 2 (ping)
-------------------------------------------
cnc1#ping fec0::6:2 

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::6:2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 304/354/424 ms
cnc1# 

cnc3#ping fec0::6:1 

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::6:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 136/184/216 ms
cnc3#
-------------------------------------------
How to check 3 (sh int tun [])
-------------------------------------------
cnc1#sh int tun 1
Tunnel1 is up, line protocol is up
 Hardware is Tunnel
 MTU 1456 bytes, BW 100 Kbit/sec, DLY 50000 usec,
 reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation TUNNEL, loopback not set
 Keepalive not set
 Tunnel source FEC0::2:1 (FastEthernet0/0), destination FEC0::4:2
 Tunnel protocol/transport GRE/IPv6
 Tunnel TTL 255
 Tunnel transport MTU 1456 bytes
 Tunnel transmit bandwidth 8000 (kbps)
 Tunnel receive bandwidth 8000 (kbps)
 Last input 00:00:03, output 00:00:04, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/0 (size/max)
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
 1506 packets input, 281796 bytes, 0 no buffer
 Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
 1593 packets output, 226200 bytes, 0 underruns
 0 output errors, 0 collisions, 0 interface resets
 0 unknown protocol drops
 0 output buffer failures, 0 output buffers swapped out
cnc1# 

cnc3#sh int tun 1
Tunnel1 is up, line protocol is up
 Hardware is Tunnel
 MTU 1456 bytes, BW 100 Kbit/sec, DLY 50000 usec,
 reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation TUNNEL, loopback not set
 Keepalive not set
 Tunnel source FEC0::4:2 (FastEthernet0/0), destination FEC0::2:1
 Tunnel protocol/transport GRE/IPv6
 Tunnel TTL 255
 Tunnel transport MTU 1456 bytes
 Tunnel transmit bandwidth 8000 (kbps)
 Tunnel receive bandwidth 8000 (kbps)
 Last input 00:00:02, output 00:00:09, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 5
 Queueing strategy: fifo
 Output queue: 0/0 (size/max)
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
 1538 packets input, 289640 bytes, 0 no buffer
 Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
 1505 packets output, 215408 bytes, 0 underruns
 0 output errors, 0 collisions, 0 interface resets
 0 unknown protocol drops
 0 output buffer failures, 0 output buffers swapped out
cnc3#
-------------------------------------------
How to check 4 (sh ipv6 route)
-------------------------------------------
cnc1#sh ipv6 route
IPv6 Routing Table - Default - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
 B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
 I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
 EX - EIGRP external
 O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
 ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
C   FEC0::1:0/112 [0/0]
 via Loopback0, directly connected
L   FEC0::1:1/128 [0/0]
 via Loopback0, receive
C   FEC0::2:0/112 [0/0]
 via FastEthernet0/0, directly connected
L   FEC0::2:1/128 [0/0]
 via FastEthernet0/0, receive
R   FEC0::4:0/112 [120/2]
 via FE80::C801:EFF:FE04:0, FastEthernet0/0
O   FEC0::5:1/128 [110/1000]
 via FE80::C802:EFF:FE58:0, Tunnel1
C   FEC0::6:0/112 [0/0]
 via Tunnel1, directly connected
L   FEC0::6:1/128 [0/0]
 via Tunnel1, receive
L   FF00::/8 [0/0]
 via Null0, receive
cnc1# 

cnc2#sh ipv6 route
IPv6 Routing Table - Default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
 B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
 I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
 EX - EIGRP external
 O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
 ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
C   FEC0::2:0/112 [0/0]
 via FastEthernet0/0, directly connected
L   FEC0::2:2/128 [0/0]
 via FastEthernet0/0, receive
C   FEC0::4:0/112 [0/0]
 via FastEthernet1/0, directly connected
L   FEC0::4:1/128 [0/0]
 via FastEthernet1/0, receive
L   FF00::/8 [0/0]
 via Null0, receive
cnc2# 

cnc3#sh ipv6 route
IPv6 Routing Table - Default - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
 B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
 I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
 EX - EIGRP external
 O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
 ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
O   FEC0::1:1/128 [110/1000]
 via FE80::C800:EFF:FE04:0, Tunnel1
R   FEC0::2:0/112 [120/2]
 via FE80::C801:EFF:FE04:1C, FastEthernet0/0
C   FEC0::4:0/112 [0/0]
 via FastEthernet0/0, directly connected
L   FEC0::4:2/128 [0/0]
 via FastEthernet0/0, receive
C   FEC0::5:0/112 [0/0]
 via Loopback0, directly connected
L   FEC0::5:1/128 [0/0]
 via Loopback0, receive
C   FEC0::6:0/112 [0/0]
 via Tunnel1, directly connected
L   FEC0::6:2/128 [0/0]
 via Tunnel1, receive
L   FF00::/8 [0/0]
 via Null0, receive
cnc3#
-------------------------------------------
How to check 5 (sh ipv6 ospf neighbor)
-------------------------------------------
cnc1#sh ipv6 ospf neighbor
Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
3.3.3.3           1   FULL/  -        00:00:21    10              Tunnel1
cnc1# 

cnc3#sh ipv6 ospf neighbor
Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
1.1.1.1           1   FULL/  -        00:00:35    10              Tunnel1
cnc3#
-------------------------------------------
How to check 6 (ping)
-------------------------------------------
cnc1#ping fec0::5:1 source loopback 0 repeat 100 

Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to FEC0::5:1, timeout is 2 seconds:
Packet sent with a source address of FEC0::1:1
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 116/350/1000 ms
cnc1# 

cnc3#ping  fec0::1:1 source loopback 0 repeat 100 

Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to FEC0::1:1, timeout is 2 seconds:
Packet sent with a source address of FEC0::5:1
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 100/176/476 ms
cnc3#
-------------------------------------------
How to check 7 (wireshark gre ipv6)

-------------------------------------------
-------------------------------------------
konfigurasi lengkap
-------------------------------------------
cnc1#sh run
Building configuration... 

Current configuration : 1335 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cnc1
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
multilink bundle-name authenticated
!
voice dsp waitstate 0
!
memory-size iomem 0
archive
 log config
 hidekeys
!
interface Loopback0
 no ip address
 ipv6 address FEC0::1:1/112
 ipv6 ospf 1 area 0
!
interface Tunnel1
 no ip address
 ipv6 address FEC0::6:1/112
 ipv6 enable
 ipv6 ospf 1 area 0
 tunnel source FastEthernet0/0
 tunnel destination FEC0::4:2
 tunnel mode gre ipv6
!
interface FastEthernet0/0
 no ip address
 duplex full
 ipv6 address FEC0::2:1/112
 ipv6 rip iwing enable
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
logging alarm informational
ipv6 router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
!
ipv6 router rip iwing
!
control-plane
!
mgcp fax t38 ecm
!
gatekeeper
 shutdown
!
line con 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
end 

cnc1# 

cnc2#sh run
Building configuration... 

Current configuration : 1039 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cnc2
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
multilink bundle-name authenticated
!
voice dsp waitstate 0
!
memory-size iomem 0
archive
 log config
 hidekeys
!
interface FastEthernet0/0
 no ip address
 duplex full
 ipv6 address FEC0::2:2/112
 ipv6 rip iwing enable
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 ipv6 address FEC0::4:1/112
 ipv6 rip iwing enable
!
interface FastEthernet1/1
 no ip address
 duplex auto
 speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
logging alarm informational
ipv6 router rip iwing
!
control-plane
!
mgcp fax t38 ecm
!
gatekeeper
 shutdown
!
line con 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
end 

cnc2# 

cnc3#sh run
Building configuration... 

Current configuration : 1335 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cnc3
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
multilink bundle-name authenticated
!
voice dsp waitstate 0
!
memory-size iomem 0
archive
 log config
 hidekeys
!
interface Loopback0
 no ip address
 ipv6 address FEC0::5:1/112
 ipv6 ospf 1 area 0
!
interface Tunnel1
 no ip address
 ipv6 address FEC0::6:2/112
 ipv6 enable
 ipv6 ospf 1 area 0
 tunnel source FastEthernet0/0
 tunnel destination FEC0::2:1
 tunnel mode gre ipv6
!
interface FastEthernet0/0
 no ip address
 duplex full
 ipv6 address FEC0::4:2/112
 ipv6 rip iwing enable
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
logging alarm informational
ipv6 router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
!
ipv6 router rip iwing
!
control-plane
!
mgcp fax t38 ecm
!
gatekeeper
 shutdown
!
line con 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
end 

cnc3#
-------------------------------------------
"Sekian dulu dan semoga bermanfaat"
ref:
[1]Cisco IOS IPv6 Configuration Guide,  
URL:http://www.cisco.com, (April 2010)
About these ads
One Comment leave one →
  1. 21 December 2011 4:00 AM

    salam networking … :)
    pengen nanya maksud dari GRE ipv6 apa?

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

Join 26 other followers

%d bloggers like this: