Skip to content

Belajar Mengkonfigurasi 6to4 tunnel

12 April 2010
Penggantian infrastruktur secara langsung pada seluruh jaringan IPv4 menuju ke IPv6 tidak
dapat dilakukan serta merta karena beberapa hal,sehingga dibutuhkan mekanisme transisi.
Mekanisme yang sering digunakan adalah model tunneling. Pada implementasinya ada banyak meka
nisme transisi tunneling yang digunakan, mekanisme tadi seperti tabel dibawah ini :

Pada kesempatan ini, kita akan belajar mengkonfigurasi 6to4 tunnel
Topology yang digunakan adalah sebagai berikut :
Peralatan yang digunakan:
--3 buah router
 -- 2 buah router harus support IPv6 (cnc1 dan cnc3)
 -- 1 buah router untuk simulasi IPv4 cloud (cnc2)
--1 buah hub
--3 buah komputer
 -- 2 buah komputer support IPv6 (com1 dan com 2)
 -- 1 buah komputer dengan wireshark,utk mengcapture
 data (komputer)
--kabel utp seperlunya

nb:cloud IPv4 sebelumnya telah disetting terlebih dahulu
menggunakan routing protocol ospfv2 dengan proses id 1

Langkah-langkahnya adalah sebagai berikut:

-Membuat Tunnel di router cnc1 dan cnc3
-------------------------------------------
cnc1#sh run int tun 1
Building configuration...

Current configuration : 149 bytes
!
interface Tunnel1
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:A41:1::1/64
 tunnel source FastEthernet0/0
 tunnel mode ipv6ip 6to4
end

ipv6 route 2002::/16 Tunnel1

cnc1#

cnc3#sh run int tun 1
Building configuration...

Current configuration : 150 bytes
!
interface Tunnel1
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:1402:1::2/64
 tunnel source FastEthernet0/1
 tunnel mode ipv6ip 6to4
end

ipv6 route 2002::/16 Tunnel1

cnc3#
-------------------------------------------
How to check 1(sh int tun [])
-------------------------------------------
cnc1#sh int tun 1
Tunnel1 is up, line protocol is up
 Hardware is Tunnel
 MTU 1514 bytes, BW 9 Kbit/sec, DLY 500000 usec,
 reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation TUNNEL, loopback not set
 Keepalive not set
 Tunnel source 192.168.10.65 (FastEthernet0/0), destination UNKNOWN
 Tunnel protocol/transport IPv6 6to4

 Fast tunneling enabled
 Tunnel transmit bandwidth 8000 (kbps)
 Tunnel receive bandwidth 8000 (kbps)
 Last input 00:01:25, output 00:01:25, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 11
 Queueing strategy: fifo
 Output queue: 0/0 (size/max)
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
 3865 packets input, 390064 bytes, 0 no buffer
 Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
 3419 packets output, 363877 bytes, 0 underruns
 0 output errors, 0 collisions, 0 interface resets
 0 unknown protocol drops
 0 output buffer failures, 0 output buffers swapped out
cnc1#

cnc1#sh int tun 1
Tunnel1 is up, line protocol is up
 Hardware is Tunnel
 MTU 1514 bytes, BW 9 Kbit/sec, DLY 500000 usec,
 reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation TUNNEL, loopback not set
 Keepalive not set
 Tunnel source 192.168.10.65 (FastEthernet0/0), destination UNKNOWN
 Tunnel protocol/transport IPv6 6to4

 Fast tunneling enabled
 Tunnel transmit bandwidth 8000 (kbps)
 Tunnel receive bandwidth 8000 (kbps)
 Last input 00:01:25, output 00:01:25, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 11
 Queueing strategy: fifo
 Output queue: 0/0 (size/max)
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
 3865 packets input, 390064 bytes, 0 no buffer
 Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
 3419 packets output, 363877 bytes, 0 underruns
 0 output errors, 0 collisions, 0 interface resets
 0 unknown protocol drops
 0 output buffer failures, 0 output buffers swapped out
cnc1#
-------------------------------------------
How to check 2(ping)
-------------------------------------------

cnc1#ping 2002:C0A8:1402:1::2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:C0A8:1402:1::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/3/4 ms
cnc1#

cnc3#ping  2002:C0A8:A41:1::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:C0A8:A41:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/1/4 ms
cnc3#
-------------------------------------------
-Menambahkan routing statis
-------------------------------------------
cnc1(config)#ipv6 route FEC0::4:0/112 2002:C0A8:1402:1::2

cnc3(config)#ipv6 route FEC0::1:0/112 2002:C0A8:A41:1::1

-------------------------------------------
How to check 3(sh ipv6 route)
-------------------------------------------
cnc1#sh ipv6 route
IPv6 Routing Table - 10 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
 U - Per-user Static route
 I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
 O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
 ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
S   2002::/16 [1/0]
 via ::, Tunnel1
C   2002:C0A8:A41:1::/64 [0/0]
 via ::, Tunnel1
L   2002:C0A8:A41:1::1/128 [0/0]
 via ::, Tunnel1
L   FE80::/10 [0/0]
 via ::, Null0
C   FEC0::1:0/112 [0/0]
 via ::, FastEthernet0/1
L   FEC0::1:1/128 [0/0]
 via ::, FastEthernet0/1
C   FEC0::2:0/112 [0/0]
 via ::, Loopback0
L   FEC0::2:1/128 [0/0]
 via ::, Loopback0
S   FEC0::4:0/112 [1/0]
 via 2002:C0A8:1402:1::2
L   FF00::/8 [0/0]
 via ::, Null0
cnc1#

cnc3#sh ipv6 route
IPv6 Routing Table - 10 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
 U - Per-user Static route
 I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
 O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
 ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
S   2002::/16 [1/0]
 via ::, Tunnel1
C   2002:C0A8:1402:1::/64 [0/0]
 via ::, Tunnel1
L   2002:C0A8:1402:1::2/128 [0/0]
 via ::, Tunnel1
L   FE80::/10 [0/0]
 via ::, Null0
S   FEC0::1:0/112 [1/0]
 via 2002:C0A8:A41:1::1
C   FEC0::3:0/112 [0/0]
 via ::, Loopback0
L   FEC0::3:1/128 [0/0]
 via ::, Loopback0
C   FEC0::4:0/112 [0/0]
 via ::, FastEthernet0/0
L   FEC0::4:1/128 [0/0]
 via ::, FastEthernet0/0
L   FF00::/8 [0/0]
 via ::, Null0
cnc3#
-------------------------------------------
Pengetesan (ping6 and treceroute6)
-------------------------------------------

root@toiletumum:/home/harry# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:1b:24:6d:49:2b  
 inet6 addr: fe80::21b:24ff:fe6d:492b/64 Scope:Link
 inet6 addr: fec0::4:2/112 Scope:Site
 UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
 RX packets:5876 errors:0 dropped:0 overruns:0 frame:0
 TX packets:8353 errors:0 dropped:0 overruns:0 carrier:0
 collisions:0 txqueuelen:1000
 RX bytes:560276 (560.2 KB)  TX bytes:695136 (695.1 KB)
 Interrupt:27 Base address:0x8000 

root@toiletumum:/home/harry# 

root@toiletumum:/home/harry# ping6 fec0::1:2
PING fec0::1:2(fec0::1:2) 56 data bytes
64 bytes from fec0::1:2: icmp_seq=1 ttl=62 time=0.823 ms
64 bytes from fec0::1:2: icmp_seq=2 ttl=62 time=0.812 ms
64 bytes from fec0::1:2: icmp_seq=3 ttl=62 time=0.790 ms
64 bytes from fec0::1:2: icmp_seq=4 ttl=62 time=0.763 ms
64 bytes from fec0::1:2: icmp_seq=5 ttl=62 time=0.836 ms
^C
--- fec0::1:2 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 3998ms
rtt min/avg/max/mdev = 0.763/0.804/0.836/0.044 ms

root@toiletumum:/home/harry# traceroute6 fec0::1:2
traceroute to fec0::1:2 (fec0::1:2) from fec0::4:2, 30 hops max, 16 byte packets
 1  fec0::4:1 (fec0::4:1)  0.755 ms  0.753 ms  0.421 ms
 2  2002:c0a8:a41:1::1 (2002:c0a8:a41:1::1)  1.329 ms  1.129 ms  1.084 ms
 3  fec0::1:2 (fec0::1:2)  0.649 ms  0.606 ms  0.472 ms
root@toiletumum:/home/harry#
-------------------------------------------
wireshark 6to4

-------------------------------------------
konfigurasi lengkapnya
-------------------------------------------
cnc1#sh run
Building configuration...

Current configuration : 1562 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname cnc1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$XnAA$IaSpaeMSOyHz8uloQd1J..
!
no aaa new-model
!
!
ip cef
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!         
ipv6 unicast-routing
ipv6 cef
!
voice-card 0
 no dspfarm
!
interface Loopback0
 ip address 10.10.10.1 255.255.255.255
 ipv6 address FEC0::2:1/112
!
interface Tunnel1
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:A41:1::1/64
 tunnel source FastEthernet0/0
 tunnel mode ipv6ip 6to4
!
interface FastEthernet0/0
 ip address 192.168.10.65 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address FEC0::1:1/112
!
router ospf 1
 log-adjacency-changes
 network 10.10.10.1 0.0.0.0 area 0
 network 192.168.10.64 0.0.0.3 area 0
!
ip forward-protocol nd
!        
ip http server
no ip http secure-server
!
ipv6 route 2002::/16 Tunnel1
ipv6 route FEC0::4:0/112 2002:C0A8:1402:1::2
 log-adjacency-changes
!
control-plane
!         
line con 0
line aux 0
line vty 0 4
 password 7 xxxx
 login
!
scheduler allocate 20000 1000
!
end

cnc1#

cnc3#sh run
Building configuration...

Current configuration : 1581 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname cnc3
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$07L9$07XS6yvACJM3wgpyRkjOZ/
!
no aaa new-model
!
!
ip cef
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
ipv6 cef
!
voice-card 0
 no dspfarm         
!
interface Loopback0
 ip address 10.10.10.3 255.255.255.255
 ipv6 address FEC0::3:1/112
!
interface Tunnel1
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:1402:1::2/64
 tunnel source FastEthernet0/1
 tunnel mode ipv6ip 6to4
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address FEC0::4:1/112
!
interface FastEthernet0/1
 ip address 192.168.20.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 10.10.10.3 0.0.0.0 area 0
 network 192.168.20.0 0.0.0.255 area 0
!
ip forward-protocol nd
!         
ip http server
no ip http secure-server
!
ipv6 route 2002::/16 Tunnel1
ipv6 route FEC0::1:0/112 2002:C0A8:A41:1::1
 log-adjacency-changes
!
control-plane         
!
line con 0
line aux 0
line vty 0 4
 password 7 xxxx
 login
!
scheduler allocate 20000 1000
!
end

cnc3#
-------------------------------------------
"Sekian dulu dan semoga bermanfaat"

ref:
[1]Cisco IOS IPv6 Configuration Guide,
URL:http://www.cisco.com, (April 2010)
About these ads
4 Comments leave one →
  1. ari permalink
    20 April 2010 2:08 AM

    mas..mau nanya…
    ini teh pake OS apa iia??
    trims…

    • 20 April 2010 5:17 AM

      Saya Pake dedicated Router Cisco Series 2800 dengan IOS ( Internetwork Operating system ) V. 12.4

  2. blablabla permalink
    8 July 2012 8:32 AM

    mas mau nanya
    kalo tunneling 6to 4 apa gak bisa make routing dinamik? misal nya OSPF???

  3. khaled permalink
    3 December 2012 2:38 PM

    saya mau tanya..gimana caranya mengkonfigurasi 6to4 pada windows 7..???
    terimakasi sebelumnya..

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

Join 26 other followers

%d bloggers like this: