Skip to content

Belajar Simulasi CISCO MPLS-L3VPN

3 February 2010
tags: , , ,

Belajar Simulasi CISCO MPLS-L3VPN

Topology yang saya gunakan adalah seperti gambar dibawah ini:

Konfigurasi IP addressnya adalah sebagai berikut:

Dan Langkah-langkahnya adalah sebagai berikut:

Pertama:
konfigure semua interface (PE1-Core-PE2)

—————core———————-
!
interface Loopback0
ip address 192.168.100.1 255.255.255.255
!
interface GigabitEthernet1/0
ip address 192.168.10.10 255.255.255.252
!
interface GigabitEthernet2/0
ip address 192.168.10.13 255.255.255.252
—————————————–

—————PE1———————–
interface Loopback0
ip address 192.168.100.2 255.255.255.255
!
interface GigabitEthernet1/0
ip address 192.168.10.9 255.255.255.252
—————————————–

—————PE2———————–
interface Loopback0
ip address 192.168.100.3 255.255.255.255
!
interface GigabitEthernet1/0
ip address 192.168.10.14 255.255.255.252
—————————————–

Kedua:Aktifkan Dynamic Routing

—————core———————-
router ospf 1
network 192.168.10.0 0.0.0.255 area 0
network 192.168.100.1 0.0.0.0 area 0
—————————————–

—————PE1———————–
router ospf 1
network 192.168.10.0 0.0.0.255 area 0
network 192.168.100.2 0.0.0.0 area 0
—————————————–

—————PE2———————–
router ospf 1
network 192.168.10.0 0.0.0.255 area 0
network 192.168.100.3 0.0.0.0 area 0
—————————————–
untuk pengecekan : ketikan show ip route

Ketiga:Aktifkan BGP

—————PE1———————–
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 192.168.100.3 remote-as 100
neighbor 192.168.100.3 update-source Loopback0
no auto-summary
—————————————–

—————PE2———————–
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 192.168.100.2 remote-as 100
neighbor 192.168.100.2 update-source Loopback0
no auto-summary
—————————————–
untuk pengecekan : ketikan show ip bgp sum

Keempat:Aktifkan MPLS
—————core———————-
ip cef
!
mpls label protocol ldp
!
mpls ldp router-id Loopback0 force
!
interface GigabitEthernet1/0
ip address 192.168.10.10 255.255.255.252
mpls ip
!
interface GigabitEthernet2/0
ip address 192.168.10.13 255.255.255.252
mpls ip
—————————————–

—————PE1———————–
ip cef
!
mpls label protocol ldp
!
mpls ldp router-id Loopback0 force
!
interface GigabitEthernet1/0
ip address 192.168.10.9 255.255.255.252
mpls ip
—————————————–

—————PE2———————–
ip cef
!
mpls label protocol ldp
!
mpls ldp router-id Loopback0 force
!
interface GigabitEthernet1/0
ip address 192.168.10.14 255.255.255.252
mpls ip
—————————————–
untuk pengecekan : ketikan show mpls ldp neighbor

Kelima:Buat Router Virtual

—————PE1———————–
ip vrf cnc1
rd 100:1
route-target export 100:1
route-target import 100:1
!
ip vrf cnc2
rd 100:2
route-target export 100:2
route-target import 100:2
!
interface GigabitEthernet2/0
ip vrf forwarding cnc1
ip address 192.168.10.2 255.255.255.252
!
interface GigabitEthernet3/0
ip vrf forwarding cnc2
ip address 192.168.10.6 255.255.255.252
—————————————–

—————PE2———————–
ip vrf cnc1
rd 100:1
route-target export 100:1
route-target import 100:1
!
ip vrf cnc2
rd 100:2
route-target export 100:2
route-target import 100:2
!
interface GigabitEthernet2/0
ip vrf forwarding cnc1
ip address 192.168.10.17 255.255.255.252
!
interface GigabitEthernet3/0
ip vrf forwarding cnc2
ip address 192.168.10.21 255.255.255.252
—————————————–
untuk pengecekan : ketikan show ip vrf (name)

Keenam: Menambahkan Routing DiRouter Virtual

—————PE1———————–
ip route vrf cnc1 10.14.200.1 255.255.255.255 192.168.10.1
ip route vrf cnc2 10.14.200.1 255.255.255.255 192.168.10.5
—————————————–

—————PE2———————–
ip route vrf cnc1 10.14.200.2 255.255.255.255 192.168.10.18
ip route vrf cnc2 10.14.200.2 255.255.255.255 192.168.10.22
—————————————–
untuk pengecekan : ketikan show ip vrf (name)

Ketujuh: Aktifkan MP-BGP

—————PE1———————–
router bgp 100
!
address-family vpnv4
neighbor 192.168.100.3 activate
neighbor 192.168.100.3 send-community both
exit-address-family
!
address-family ipv4 vrf cnc2
redistribute connected
redistribute static
no synchronization
exit-address-family
!
address-family ipv4 vrf cnc1
redistribute connected
redistribute static
no synchronization
exit-address-family
—————————————–

—————PE2———————–
router bgp 100
!
address-family vpnv4
neighbor 192.168.100.2 activate
neighbor 192.168.100.2 send-community both
exit-address-family
!
address-family ipv4 vrf cnc2
redistribute connected
redistribute static
no synchronization
exit-address-family
!
address-family ipv4 vrf cnc1
redistribute connected
redistribute static
no synchronization
exit-address-family
—————————————–

Kedelapan: Mengaktifkan CE dan Pengujian End-to-end

—————cnc1_a——————–

cnc1_a#sh run
!
version 12.4
!
hostname cnc1_a
!
enable secret 5 $1$3b6r$LdDX1wajQUqjGJPOpxH0F1
!
ip cef
!
interface Loopback0
ip address 10.14.200.1 255.255.255.255
!
interface GigabitEthernet1/0
ip address 192.168.10.1 255.255.255.252
negotiation auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.10.2
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
password 7 xxxx
login
!
end

cnc1_a#
—————————————–
————–cnc2_y———————

cnc2_y#sh run
Building configuration…

!
version 12.4
!
hostname cnc2_y
!
logging message-counter syslog
enable secret 5 $1$2M75$hih5UEKQq2Lgtw9v8te6n/
!
ip cef
!

interface Loopback0
ip address 10.14.200.2 255.255.255.255
!
interface GigabitEthernet1/0
ip address 192.168.10.22 255.255.255.252
negotiation auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.10.21
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
password 7 xxxx
login
!
end

cnc2_y#
—————————————–
————–cnc1_b———————

cnc1_b#sh run
!
version 12.4
!
hostname cnc1_b
!
enable secret 5 $1$BNrz$gJwJXNoaDp5X0F2ViVllF/
ip cef
!
interface Loopback0
ip address 10.14.200.2 255.255.255.255
!
interface GigabitEthernet1/0
ip address 192.168.10.18 255.255.255.252
negotiation auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.10.17
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
password xxxx
login
!
end

cnc1_b#
—————————————–
————cnc2_y———————–
cnc2_y#sh run
Building configuration…

!
version 12.4
!
hostname cnc2_y
!
ip cef
!
interface Loopback0
ip address 10.14.200.2 255.255.255.255
!
interface GigabitEthernet1/0
ip address 192.168.10.22 255.255.255.252
negotiation auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.10.21
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
password 7 xxxx
login
!
end

cnc2_y#
—————————————–
untuk pengecekan : pergunakan perintah ping dan telnet

“————Sekian dulu, semoga bermanfaat——————“

About these ads
2 Comments leave one →
  1. 15 September 2010 8:57 AM

    Mas iwing,,

    Untuk pengetesan MPLS ini melalui ping dari cnc1_a ke cnc1_b ?
    Jika hasilnya reply,, apakah ping ini merupakan dari sistem MPLS nya atau routing ??

    Thx

    • 15 September 2010 1:17 PM

      coba jawab xixixixi, maaf kalau salah…
      karena icmp berada pada layer 3 sedangkan si mpls ada pada layer 2,5 maka pengujian ping
      ini sebenarnya ….. mungkin sistem routing, sebagai contoh jika jaringan mpls kita ada yang bermasalah
      misal ldp broken, kita masih bisa ngeping (padahal mplsnya ga jalan) maka kalau ingin menguji mpls
      command nya adalah router#ping mpls ………. (silahkan mengacu pada oem mpls cisco). dan juga disisi client
      sudah melewati PE jadi Label sudah dipop (dicopot)

      CMIIW

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

Join 27 other followers

%d bloggers like this: